summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2016-01-25 16:29:53 +0100
committerSebastian Wolf2016-01-25 16:29:53 +0100
commit76c71619f314a532dba1ff5e2997dfd69dfe19f9 (patch)
tree564a7c112757054756ae32f5ec4e7c14c0588577
downloadaur-76c71619f314a532dba1ff5e2997dfd69dfe19f9.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d38fe0b9d86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 15:28:24 UTC 2016
+pkgbase = acme-git
+ pkgdesc = A free crossassembler, that can produce code for the 6502, 6510, 65c02 and 65816 processors
+ pkgver = r66.181f448
+ pkgrel = 1
+ url = https://github.com/meonwax/acme
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = acme
+ conflicts = acme
+ source = git+https://github.com/meonwax/acme.git
+ sha256sums = SKIP
+
+pkgname = acme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a64503f59a12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sebastian Wolf <fatmike303 at googlemail dot com>
+pkgname=acme-git
+_pkgname=acme
+pkgver=r66.181f448
+pkgrel=1
+pkgdesc="A free crossassembler, that can produce code for the 6502, 6510, 65c02 and 65816 processors"
+arch=('i686' 'x86_64')
+url="https://github.com/meonwax/acme"
+license=('GPL')
+source=('git+https://github.com/meonwax/acme.git')
+makedepends=('git')
+conflicts=('acme')
+provides=('acme')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/src"
+ install -D -m755 acme ${pkgdir}/usr/bin/acme
+}