summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Morales2015-08-26 17:29:18 -0300
committerFelipe Morales2015-08-26 17:29:18 -0300
commitb1cfcf2b730d974e1ac4741b1e0a22dfca286c6c (patch)
tree75287730b088dbab1a4adc970493258eed370dc8
parentdda39bc9642200133437f99656199f26fe6a077c (diff)
downloadaur-b1cfcf2b730d974e1ac4741b1e0a22dfca286c6c.tar.gz
several changes
rename binary to acme-sac, for compatibility with plan9port. Use lib32 libraries explicitely (32bit dependencies are commented out)
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d2485336f63..21a663b55b23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Felipe Morales <hel.sheep@gmail.com>
pkgname=acme-sac
pkgver=0.14
-pkgrel=3
+pkgrel=4
pkgdesc="Programmer's editor and shell, running over Inferno"
-arch=('any')
+arch=('x86_64')
+#arch=('i386')
url="http://code.google.com/p/acme-sac/"
license=('GPL')
-depends=('libx11' 'libxext' 'gcc')
+depends=('lib32-libx11' 'lib32-libxext' 'gcc-multilib')
+#depends=('gcc' 'libx11' 'libxext')
provides=('acme')
source=(http://acme-sac.googlecode.com/files/acme-sac_0.14_i386.deb)
noextract=()
-md5sums=(178477dd90abb650fd6b1f1babb3edf8)
+md5sums=(178477dd90abb650fd6b1f1babb3edf8)
package() {
cd "$srcdir/"
tar -xzf data.tar.gz
+ mv usr/bin/acme usr/bin/acme-sac
cp -r usr "$pkgdir/"
}