summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2016-08-26 10:57:08 +0200
committerNoel Kuntze2016-08-26 10:57:08 +0200
commit1a91c6aaed7979d89509c256e63b3411608d1b94 (patch)
tree38cca8685cfe57776c02484315172354fc322064
downloadaur-1a91c6aaed7979d89509c256e63b3411608d1b94.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bdce7c70e37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Aug 26 08:57:03 UTC 2016
+pkgbase = acmetool
+ pkgdesc = Acmetool is an easy-to-use command line tool for automatically acquiring certificates from ACME servers (such as Let's Encrypt)
+ pkgver = 0.0.56
+ pkgrel = 1
+ url = https://github.com/hlandau/acme
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = go
+
+pkgname = acmetool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c7a32f2dae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Mikael Eriksson <mikael_eriksson@miffe.org>
+
+pkgname=acmetool
+pkgver=0.0.56
+pkgrel=1
+pkgdesc="Acmetool is an easy-to-use command line tool for automatically acquiring certificates from ACME servers (such as Let's Encrypt)"
+arch=(i686 x86_64 armv7h)
+url="https://github.com/hlandau/acme"
+license=('MIT')
+depends=()
+makedepends=(go)
+
+build() {
+ GOPATH="$srcdir" go get -v -x github.com/hlandau/acme/cmd/acmetool
+}
+
+package() {
+ install -Dm755 "$srcdir/bin/acmetool" "$pkgdir/usr/bin/acmetool"
+}