summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-05 00:09:57 +0800
committerzxp198210052023-06-05 00:09:57 +0800
commitc3df59ffc44d1fb868c7056d3647371f6a59f5cf (patch)
tree6a6ecf09966eb2746fc9d15545767ef2eeba7049
downloadaur-c3df59ffc44d1fb868c7056d3647371f6a59f5cf.tar.gz
first release
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60a31400d7ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = acodec-bin
+ pkgdesc = Encoder & decoder for various algorithms with graphical user interface.
+ pkgver = 2.5.3
+ pkgrel = 1
+ url = https://github.com/albertus82/acodec
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = armv7h
+ license = GPL3
+ depends = java-runtime
+ depends = hicolor-icon-theme
+ depends = sh
+ conflicts = acodec
+ noextract = acodec-2.5.3-x86_64.tar.gz
+ options = !strip
+ source_x86_64 = acodec-2.5.3-x86_64.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-x86_64-bin.tar.gz
+ sha256sums_x86_64 = 484305580b11565c256057db00d3c5f2be27575a763bc66912c18f65205d9c93
+ source_i686 = acodec-2.5.3-i686.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-x86-bin.tar.gz
+ sha256sums_i686 = 410987e5d2ce450c93c09d1a4e77f82d3d5feea263cae00d4a223c4ead651656
+ source_aarch64 = acodec-2.5.3-aarch64.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-aarch64-bin.tar.gz
+ sha256sums_aarch64 = 10f8dd863dba60161595816e80a33b55017d6f271b81b836a3481c6f9cf5289d
+ source_armv7h = acodec-2.5.3-armv7h.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-armhf-bin.tar.gz
+ sha256sums_armv7h = 37c56e6f284ad91162956d37b35d46d7d12aed724cf2aaf8a80466abb086275d
+
+pkgname = acodec-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cba0d3d3b061
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="acodec-bin"
+pkgver=2.5.3
+pkgrel=1
+pkgdesc="Encoder & decoder for various algorithms with graphical user interface."
+arch=("x86_64" "i686" "aarch64" "armv7h")
+url="https://github.com/albertus82/acodec"
+license=('GPL3')
+depends=('java-runtime' 'hicolor-icon-theme' 'sh')
+conflicts=("${pkgname%-bin}")
+options=(!strip)
+noextract=("${pkgname%-bin}-${pkgver}-${CARCH}.tar.gz")
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-armhf-bin.tar.gz")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-aarch64-bin.tar.gz")
+source_i686=("${pkgname%-bin}-${pkgver}-i686.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-x86-bin.tar.gz")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-x86_64-bin.tar.gz")
+sha256sums_x86_64=('484305580b11565c256057db00d3c5f2be27575a763bc66912c18f65205d9c93')
+sha256sums_i686=('410987e5d2ce450c93c09d1a4e77f82d3d5feea263cae00d4a223c4ead651656')
+sha256sums_aarch64=('10f8dd863dba60161595816e80a33b55017d6f271b81b836a3481c6f9cf5289d')
+sha256sums_armv7h=('37c56e6f284ad91162956d37b35d46d7d12aed724cf2aaf8a80466abb086275d')
+package() {
+ install -Dm755 -d "${pkgdir}/opt"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.tar.gz" -C "${pkgdir}/opt"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/LICENSE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ for _icons in 16x16 20x20 24x24 32x32 40x40 48x48 64x64 96x96 128x128 256x256;do
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/icon/${_icons}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
+ gendesk -f --icon "${pkgname%-bin}" --categories "Utility" --name "${pkgname%-bin}" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}w.desktop"
+ sed "s|Name=${pkgname%-bin}|Name=${pkgname%-bin}w|g;s|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}.sh|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}w.sh|g" \
+ -i "${pkgdir}/usr/share/applications/${pkgname%-bin}w.desktop"
+} \ No newline at end of file