summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-31 17:45:31 +0800
committerzxp198210052023-07-31 17:45:31 +0800
commitfedcb992c2e2877c0f1377d0995ed5212eb342d3 (patch)
treebf0a8b755ce36d9d5ae286a119c53f76ef315418
parentc3df59ffc44d1fb868c7056d3647371f6a59f5cf (diff)
downloadaur-fedcb992c2e2877c0f1377d0995ed5212eb342d3.tar.gz
optimized PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60a31400d7ac..ac37bf3453dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = acodec-bin
pkgdesc = Encoder & decoder for various algorithms with graphical user interface.
pkgver = 2.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/albertus82/acodec
- arch = x86_64
- arch = i686
arch = aarch64
arch = armv7h
+ arch = i686
+ arch = x86_64
license = GPL3
depends = java-runtime
depends = hicolor-icon-theme
depends = sh
+ provides = acodec-2.5.3
conflicts = acodec
noextract = acodec-2.5.3-x86_64.tar.gz
- options = !strip
- source_x86_64 = acodec-2.5.3-x86_64.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-x86_64-bin.tar.gz
- sha256sums_x86_64 = 484305580b11565c256057db00d3c5f2be27575a763bc66912c18f65205d9c93
- source_i686 = acodec-2.5.3-i686.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-x86-bin.tar.gz
- sha256sums_i686 = 410987e5d2ce450c93c09d1a4e77f82d3d5feea263cae00d4a223c4ead651656
source_aarch64 = acodec-2.5.3-aarch64.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-aarch64-bin.tar.gz
sha256sums_aarch64 = 10f8dd863dba60161595816e80a33b55017d6f271b81b836a3481c6f9cf5289d
source_armv7h = acodec-2.5.3-armv7h.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-armhf-bin.tar.gz
sha256sums_armv7h = 37c56e6f284ad91162956d37b35d46d7d12aed724cf2aaf8a80466abb086275d
+ source_i686 = acodec-2.5.3-i686.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-x86-bin.tar.gz
+ sha256sums_i686 = 410987e5d2ce450c93c09d1a4e77f82d3d5feea263cae00d4a223c4ead651656
+ source_x86_64 = acodec-2.5.3-x86_64.tar.gz::https://github.com/albertus82/acodec/releases/download/v2.5.3/acodec-2.5.3-gtk-linux-x86_64-bin.tar.gz
+ sha256sums_x86_64 = 484305580b11565c256057db00d3c5f2be27575a763bc66912c18f65205d9c93
pkgname = acodec-bin
diff --git a/PKGBUILD b/PKGBUILD
index cba0d3d3b061..a4eccd8031a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,36 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="acodec-bin"
pkgver=2.5.3
-pkgrel=1
+pkgrel=2
pkgdesc="Encoder & decoder for various algorithms with graphical user interface."
-arch=("x86_64" "i686" "aarch64" "armv7h")
+arch=("aarch64" "armv7h" "i686" "x86_64")
url="https://github.com/albertus82/acodec"
license=('GPL3')
depends=('java-runtime' 'hicolor-icon-theme' 'sh')
+provides=("${pkgname%-bin}-${pkgver}")
conflicts=("${pkgname%-bin}")
-options=(!strip)
noextract=("${pkgname%-bin}-${pkgver}-${CARCH}.tar.gz")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-armhf-bin.tar.gz")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-aarch64-bin.tar.gz")
source_i686=("${pkgname%-bin}-${pkgver}-i686.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-x86-bin.tar.gz")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-gtk-linux-x86_64-bin.tar.gz")
-sha256sums_x86_64=('484305580b11565c256057db00d3c5f2be27575a763bc66912c18f65205d9c93')
-sha256sums_i686=('410987e5d2ce450c93c09d1a4e77f82d3d5feea263cae00d4a223c4ead651656')
sha256sums_aarch64=('10f8dd863dba60161595816e80a33b55017d6f271b81b836a3481c6f9cf5289d')
sha256sums_armv7h=('37c56e6f284ad91162956d37b35d46d7d12aed724cf2aaf8a80466abb086275d')
+sha256sums_i686=('410987e5d2ce450c93c09d1a4e77f82d3d5feea263cae00d4a223c4ead651656')
+sha256sums_x86_64=('484305580b11565c256057db00d3c5f2be27575a763bc66912c18f65205d9c93')
package() {
- install -Dm755 -d "${pkgdir}/opt"
+ install -Dm755 -d "${pkgdir}/opt" "${pkgdir}/usr/bin"
bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.tar.gz" -C "${pkgdir}/opt"
install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/LICENSE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
for _icons in 16x16 20x20 24x24 32x32 40x40 48x48 64x64 96x96 128x128 256x256;do
install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/icon/${_icons}.png" \
"${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
done
- gendesk -f --icon "${pkgname%-bin}" --categories "Utility" --name "${pkgname%-bin}" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "Utility" --name "${pkgname%-bin}" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}.sh"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}w.desktop"
sed "s|Name=${pkgname%-bin}|Name=${pkgname%-bin}w|g;s|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}.sh|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}w.sh|g" \
-i "${pkgdir}/usr/share/applications/${pkgname%-bin}w.desktop"
+ ln -s "/opt/${pkgname%-bin}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ ln -s "/opt/${pkgname%-bin}/${pkgname%-bin}w.sh" "${pkgdir}/usr/bin/${pkgname%-bin}w"
} \ No newline at end of file