summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Panteleev2016-09-07 07:05:29 +0000
committerVladimir Panteleev2016-09-07 07:05:29 +0000
commit7d08e7f12c6620437539870313dcbf8673ce18c4 (patch)
treefb09904b12f690e2386fdea29c2338fcf5ad22ef
downloadaur-7d08e7f12c6620437539870313dcbf8673ce18c4.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
-rw-r--r--license.txt7
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..729e0ce0749b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Sep 7 07:04:52 UTC 2016
+pkgbase = aconfmgr-git
+ pkgdesc = A configuration manager for Arch Linux
+ pkgver = r92.a1ed28e
+ pkgrel = 1
+ url = https://github.com/CyberShadow/aconfmgr
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = bash
+ depends = git
+ depends = pacman
+ depends = pacutils
+ optdepends = pacaur: pacaur integration
+ optdepends = yaourt: yaourt integration
+ optdepends = augeas: configuration file editing
+ source = git+https://github.com/CyberShadow/aconfmgr
+ source = license.txt
+ md5sums = SKIP
+ md5sums = 2c153a787e3a0974a4d4c5a005c53d99
+
+pkgname = aconfmgr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37af8004aea8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Vladimir Panteleev <arch-pkg at thecybershadow.net>
+
+pkgname=aconfmgr-git
+pkgver=r92.a1ed28e
+pkgrel=1
+pkgdesc="A configuration manager for Arch Linux"
+arch=('any')
+url="https://github.com/CyberShadow/aconfmgr"
+license=('MIT')
+depends=('bash' 'git' 'pacman' 'pacutils')
+makedepends=('git')
+optdepends=('pacaur: pacaur integration'
+ 'yaourt: yaourt integration'
+ 'augeas: configuration file editing')
+source=("git+https://github.com/CyberShadow/aconfmgr"
+ "license.txt")
+md5sums=('SKIP'
+ '2c153a787e3a0974a4d4c5a005c53d99')
+
+pkgver() {
+ cd "$srcdir/aconfmgr"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -D -m755 -t "$pkgdir/usr/bin" "$srcdir/aconfmgr/aconfmgr"
+ install -D -m644 -t "$pkgdir/usr/lib/aconfmgr" "$srcdir/aconfmgr/src/"*
+ install -D -m644 -t "$pkgdir/usr/share/doc/aconfmgr" "$srcdir/aconfmgr/README.md"
+ install -D -m644 -t "$pkgdir/usr/share/man/man1" "$srcdir/aconfmgr/aconfmgr.1"
+ install -D -m644 -t "$pkgdir/usr/share/licenses/$pkgname" license.txt
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..f70a03953adb
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,7 @@
+Copyright (c) 2016 aconfmgr authors.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.