summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2014-10-21 01:59:52 +0200
committerJohannes Dewender2014-10-21 01:59:52 +0200
commit15448405a55a955e1d57c646dd5d50cac415a71c (patch)
tree0466cbc69d428e5613685289c0a3ceaaac3ac321
downloadaur-15448405a55a955e1d57c646dd5d50cac415a71c.tar.gz
acousticbrainz-git: created
This still uses the pre-made essentia binary provided by acousticbrainz.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD47
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccfc9932184f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = acousticbrainz-client-git
+ pkgdesc = client to upload data to an acousticbrainz server
+ pkgver = r36.58014e9
+ pkgrel = 1
+ url = http://acousticbrainz.org/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = python2-requests
+ source = git+https://github.com/MTG/acousticbrainz-client.git
+ source = http://acousticbrainz.org/static/download/essentia-extractor-21ef5f41f15ed1f80c8f9b36802430055d3b93e9-linux-.tar.gz
+ md5sums = SKIP
+ md5sums = 4fd57bc2fd9ed3755d62b016c72e68bc
+
+pkgname = acousticbrainz-client-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78d37fea394e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=acousticbrainz-client-git
+_pkgname=acousticbrainz-client
+_python=python2
+pkgver=r36.58014e9
+pkgrel=1
+pkgdesc="client to upload data to an acousticbrainz server"
+arch=('x86_64' 'i686')
+url="http://acousticbrainz.org/"
+license=('GPL3')
+depends=('python2-requests')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+options=()
+source=("git+https://github.com/MTG/$_pkgname.git")
+md5sums=('SKIP')
+
+# use binary essentia for now
+_EXT_HASH=21ef5f41f15ed1f80c8f9b36802430055d3b93e9
+_EXT="http://acousticbrainz.org/static/download/essentia-extractor-$_EXT_HASH-linux-$CARCH"
+source+=("$_EXT.tar.gz")
+if [ "$CARCH" = "x86_64" ]; then
+ md5sums+=('4aabb509dfc86530cdbecbdfdff6ab7d')
+else
+ md5sums+=('4fd57bc2fd9ed3755d62b016c72e68bc')
+fi
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_EXT"
+ cp streaming_extractor_music ../$_pkgname
+ cd "$srcdir/$_pkgname"
+ $_python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ $_python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: