summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZuyi Hu2015-06-20 18:36:56 +0800
committerZuyi Hu2015-06-20 18:36:56 +0800
commit19855abf81b841d5de1352b255310ae89be5ea7e (patch)
tree5cdf0cf2e1e7d11e1f7096d44b4dd7d8416e0a06
downloadaur-19855abf81b841d5de1352b255310ae89be5ea7e.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
-rw-r--r--acpi_call-pf.install14
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa757557b4ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = acpi_call-pf
+ pkgdesc = A linux-pf kernel module that enables calls to ACPI methods through /proc/acpi/call
+ pkgver = 1.1.0
+ pkgrel = 15
+ url = http://github.com/mkottman/acpi_call
+ install = acpi_call-pf.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = linux-pf-headers>=4.0
+ makedepends = linux-pf-headers<4.1
+ depends = linux-pf>=4.0
+ depends = linux-pf<4.1
+ provides = acpi_call
+ source = http://github.com/mkottman/acpi_call/archive/v1.1.0.tar.gz
+ sha256sums = d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0
+
+pkgname = acpi_call-pf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22ed73067157
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id$
+# Maintainer: Zuyi Hu <hzy0668808@gmail.com>
+# Contributor: Adam Hirst <adam@aphirst.karoo.co.uk>
+# Contributor: Maxime Gauduin <alucryd@gmail.com>
+# Contributor: mortzu <me@mortzu.de>
+# Contributor: fnord0 <fnord0@riseup.net>
+
+pkgname=acpi_call-pf
+pkgver=1.1.0
+pkgrel=15
+_extramodules=extramodules-4.0-pf
+pkgdesc='A linux-pf kernel module that enables calls to ACPI methods through /proc/acpi/call'
+arch=('i686' 'x86_64')
+url="http://github.com/mkottman/${pkgname%-*}"
+license=('GPL')
+depends=('linux-pf>=4.0' 'linux-pf<4.1')
+makedepends=('linux-pf-headers>=4.0' 'linux-pf-headers<4.1')
+provides=("${pkgname%-*}")
+install="${pkgname}.install"
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0')
+
+build() {
+ cd ${pkgname%-*}-${pkgver}
+
+ sed -i '9s/acpi/linux/' acpi_call.c
+
+ _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+
+ make KVERSION="${_kernver}"
+}
+
+package() {
+ cd ${pkgname%-*}-${pkgver}
+
+ install -dm 755 "${pkgdir}"/usr/lib/{modules/${_extramodules},modules-load.d}
+ install -m 644 ${pkgname%-*}.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/
+ gzip "${pkgdir}"/usr/lib/modules/${_extramodules}/${pkgname%-*}.ko
+ echo ${pkgname%-*} > "${pkgdir}"/usr/lib/modules-load.d/${pkgname}.conf
+
+ install -dm 755 "${pkgdir}"/usr/share/${pkgname}
+ cp -dr --no-preserve='ownership' {examples,support} "${pkgdir}"/usr/share/${pkgname}/
+}
+
+# vim: ts=2 sw=2 et:
+
diff --git a/acpi_call-pf.install b/acpi_call-pf.install
new file mode 100644
index 000000000000..33e0e0603632
--- /dev/null
+++ b/acpi_call-pf.install
@@ -0,0 +1,14 @@
+post_install() {
+ _extramodules=extramodules-4.0-pf
+ depmod $(cat /usr/lib/modules/${_extramodules}/version)
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: