summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Pozolotin2016-06-14 22:58:08 +0000
committerAndrei Pozolotin2016-06-14 22:58:08 +0000
commit7d7df40506af4798da23a898855cfda6e7f230e5 (patch)
tree80bc3d5cbcf16b91c649424e41448d1fc07c53f6
parent11d2c239b71ec35d3a652f11b20edcbbfee0f5e0 (diff)
downloadaur-7d7df40506af4798da23a898855cfda6e7f230e5.tar.gz
upstream update
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
-rwxr-xr-xbuild.sh28
-rw-r--r--lib.go.patch10
5 files changed, 4 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e59b2a69f66..4209730592b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = acpush
pkgdesc = App Container Server Push Command
pkgver = 0.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/appc/acpush
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 08eb2a15d553..ad27df29fdeb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,6 +4,7 @@
# generated resources
/*/
/*.xz
+/*.gz
/*.log
# build resources
diff --git a/PKGBUILD b/PKGBUILD
index 9dcfb4a9fabe..dd5b28d9d7f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgdesc='App Container Server Push Command'
pkgname=acpush
pkgver=0.0.0 # TODO pending release
-pkgrel=3
+pkgrel=4
url="https://github.com/appc/$pkgname"
source=("git+${url}.git")
makedepends=('git' 'go')
@@ -16,8 +16,6 @@ prepare() { # TODO pending release
local target=$([[ $pkgver == "0.0.0" ]] && printf "master" || printf "v$pkgver")
git -C "$repo" checkout --quiet "$target" # checkout proper version
git -C "$repo" status # verify working repo change
- cp -f $base/build.sh $repo/build # TODO this file is to come from upstream
- patch -d "$repo" -p0 < "$base/lib.go.patch"
}
# 2.
@@ -34,5 +32,5 @@ check() {
# 4.
package() {
cd "$pkgname"
- install -D -m755 "./bin/acpush" "$pkgdir/usr/bin/acpush"
+ install -D -m755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
}
diff --git a/build.sh b/build.sh
deleted file mode 100755
index 20291de23448..000000000000
--- a/build.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/usr/bin/env bash
-set -e
-
-# TODO this file is to come from upstream
-# made after prototype https://github.com/appc/acbuild/blob/master/build
-
-DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
-
-NAME="acpush"
-ORG_PATH="github.com/appc"
-REPO_PATH="${ORG_PATH}/${NAME}"
-VERSION=$(cd "${DIR}" && git describe --always)
-GLDFLAGS="-X ${REPO_PATH}/lib.Version=${VERSION}"
-
-if [ ! -h gopath/src/${REPO_PATH} ]; then
- mkdir -p gopath/src/${ORG_PATH}
- ln -s ../../../.. gopath/src/${REPO_PATH} || exit 255
-fi
-
-export GOBIN=${DIR}/bin
-export GOPATH=${DIR}/Godeps/_workspace:${DIR}/gopath
-
-eval $(go env)
-export GOOS GOARCH
-export CGO_ENABLED=1
-
-echo "Building $NAME ..."
-go build -o ${GOBIN}/${NAME} -ldflags "${GLDFLAGS}" ${REPO_PATH}
diff --git a/lib.go.patch b/lib.go.patch
deleted file mode 100644
index 7ad02a90fce1..000000000000
--- a/lib.go.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/lib.go 2016-06-12 15:17:59.198364508 +0000
-+++ lib/lib.go 2016-06-12 15:19:42.419076228 +0000
-@@ -23,7 +23,7 @@
- "io/ioutil"
- "net/http"
- "os"
-- "runtime"
-+ // "runtime" // https://github.com/appc/acpush/issues/3
- "strings"
- "time"