summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2019-10-27 21:52:30 +0100
committermorguldir2019-10-27 21:52:30 +0100
commit1cd8c890484e26bccfeb081500720947a6c326d5 (patch)
tree7e32be006093fef2eb510147e026aaf1a5d22057
downloadaur-1cd8c890484e26bccfeb081500720947a6c326d5.tar.gz
Adapt from acquisition
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc4f492857be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = acquisition-git
+ pkgdesc = Inventory management tool for Path of Exile.
+ pkgver = 0.8b.r6.gbea4121
+ pkgrel = 1
+ url = https://github.com/xyzz/acquisition
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-webengine
+ provides = acquisition
+ source = git+https://github.com/xyzz/acquisition
+ sha256sums = SKIP
+
+pkgname = acquisition-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c3338bd635d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+acquisition*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a0d9aabf64a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: morguldir <morguldir@protonmail.com>
+
+_pkgname=acquisition
+pkgname=acquisition-git
+pkgver=0.8b.r6.gbea4121
+pkgrel=1
+pkgdesc='Inventory management tool for Path of Exile.'
+arch=(x86_64)
+license=(GPL)
+url='https://github.com/xyzz/acquisition'
+depends=(qt5-base qt5-webengine)
+makedepends=(boost git)
+provides=(acquisition)
+source=("git+https://github.com/xyzz/acquisition")
+sha256sums=(SKIP)
+
+pkgver()
+{
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build()
+{
+ cd $_pkgname
+ qmake && make
+}
+
+package()
+{
+ cd $_pkgname
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 "acquisition" "$pkgdir/usr/bin/acquisition"
+}