summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2024-01-17 23:42:54 -0500
committerAndrew O'Neill2024-01-17 23:42:54 -0500
commit2b86ac314d75a4b0e0b145676b8293ca51ecc28c (patch)
tree9b97d390818fd8e3a7cbbe5d5e14b8e02f8169b4
parent875d39f861edbde4b52c1ba5fa9d3eb22263c8c3 (diff)
downloadaur-2b86ac314d75a4b0e0b145676b8293ca51ecc28c.tar.gz
Update version to 3.10.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 39 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2478666b1a4d..483216e4cafa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,26 @@
pkgbase = actiona
pkgdesc = A task automation tool that allows you to create and execute action lists
- pkgver = 3.10.1
+ pkgver = 3.10.2
pkgrel = 1
url = https://wiki.actiona.tools
arch = x86_64
license = GPL3
makedepends = qt5-tools
makedepends = boost
- makedepends = opencv
+ makedepends = cpp-mini
depends = qt5-script
depends = qt5-xmlpatterns
depends = qt5-x11extras
depends = qt5-multimedia
depends = libnotify
depends = qt5-speech
- source = actiona-3.10.1.tar.gz::https://github.com/Jmgr/actiona/archive/v3.10.1.tar.gz
- sha256sums = 447065e380f8f37db4c8af01df8e1b9d7189cd256205f758845b71d8de6f37ea
+ depends = opencv
+ depends = qt6-base
+ depends = hdf5
+ depends = glew
+ depends = vtk
+ options = !buildflags
+ source = actiona-3.10.2.tar.gz::https://github.com/Jmgr/actiona/archive/v3.10.2.tar.gz
+ sha256sums = f24196960302dd961ee7d97264669fc569812ecfceda5f80ddf22235d1dd486e
pkgname = actiona
diff --git a/PKGBUILD b/PKGBUILD
index 5ee5683f33dd..51dd2ff9366d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,49 @@
# Maintainer: Andrew O'Neill <andrew at haunted dot sh>
pkgname=actiona
-pkgver=3.10.1
+pkgver=3.10.2
pkgrel=1
pkgdesc='A task automation tool that allows you to create and execute action lists'
arch=('x86_64')
url='https://wiki.actiona.tools'
license=('GPL3')
-depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'libnotify' 'qt5-speech')
-makedepends=('qt5-tools' 'boost' 'opencv')
+options=('!buildflags')
+depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'libnotify' 'qt5-speech' 'opencv' 'qt6-base' 'hdf5' 'glew' 'vtk')
+makedepends=('qt5-tools' 'boost' 'cpp-mini')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('447065e380f8f37db4c8af01df8e1b9d7189cd256205f758845b71d8de6f37ea')
+sha256sums=('f24196960302dd961ee7d97264669fc569812ecfceda5f80ddf22235d1dd486e')
build() {
cd "${pkgname}-${pkgver}"
- qmake-qt5 -r PREFIX=/usr PKGCONFIG_OPENCV=opencv4
+ sed -i '28 i set(CMAKE_INSTALL_RPATH "/usr/lib/actiona")' CMakeLists.txt
+ sed -i '28 i set(CMAKE_BUILD_WITH_INSTALL_RPATH ON)' CMakeLists.txt
+ sed -i 's/loadActionPacks(QApplication::applicationDirPath() + QStringLiteral("\/actions")/loadActionPacks(QStringLiteral("\/usr\/lib\/actiona\/actions")/' gui/src/mainwindow.cpp
+
+ mkdir build
+ cd build
+ cmake ..
make
- make locale_release
}
package() {
cd "${pkgname}-${pkgver}"
- make INSTALL_ROOT="${pkgdir}" install
+ install -Dm644 actiona.desktop -t ${pkgdir}/usr/share/applications
+ install -Dm644 gui/icons/actiona.png -t ${pkgdir}/usr/share/icons/hicolor/48x48/apps
+ install -Dm644 gui/icons/actiona.png -t ${pkgdir}/usr/share/pixmaps
+ install -Dm644 docs/*.1 -t ${pkgdir}/usr/share/man/man1
+ install -Dm644 docs/actiona.xml -t ${pkgdir}/usr/share/mime/packages
+ install -Dm644 docs/examples/* -t ${pkgdir}/usr/share/actiona/examples
+ install -Dm644 LICENSE -t ${pkgdir}/usr/share/licenses/actiona
+
+ cd build
+
+ install -Dm755 actexec -t ${pkgdir}/usr/bin
+ install -Dm755 actiona -t ${pkgdir}/usr/bin
+ install -Dm755 actions/*.so -t ${pkgdir}/usr/lib/actiona/actions
+ install -Dm755 actiontools/actiontools.so -t ${pkgdir}/usr/lib/actiona
+ install -Dm755 execution/execution.so -t ${pkgdir}/usr/lib/actiona
+ install -Dm755 tools/tools.so -t ${pkgdir}/usr/lib/actiona
+ install -Dm644 translations/*.qm -t ${pkgdir}/usr/share/actiona/locale
}