summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2019-12-23 09:39:38 -0500
committerAndrew O'Neill2019-12-23 09:39:38 -0500
commit4e4cd35fe66efa55fba199444707af0723e1f00c (patch)
tree152582a145776e0d52434e9c16cc97a08f89c800
parent166d684e1c5f058328fa6280b00ab7531fa07c61 (diff)
downloadaur-4e4cd35fe66efa55fba199444707af0723e1f00c.tar.gz
Include the QKeyEvent header explicitly
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--actiona.patch21
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 097e4cde5517..52198573a891 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = actiona
pkgdesc = A task automation tool that allows you to create and execute action lists
pkgver = 3.10.0
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.actiona.tools
arch = x86_64
license = GPL3
@@ -17,7 +17,7 @@ pkgbase = actiona
source = https://github.com/Jmgr/actiona/archive/v3.10.0.tar.gz
source = actiona.patch
sha256sums = 7f7a6ecef82ec51fc5d92e41a9d39d1de190135b1fb6293318feb1d88ceb8757
- sha256sums = f359c8457947fb248d95bae8dd2dd59feaa01aa29b7b778963bc0dc1c7fd963f
+ sha256sums = 92b1368978b1feb0620095a21b95737d93839ff4bf5f97ec2f1c2b2a1ab4f5ea
pkgname = actiona
diff --git a/PKGBUILD b/PKGBUILD
index 4064ff91a367..448cc5fa7bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname=actiona
pkgver=3.10.0
-pkgrel=2
-pkgdesc="A task automation tool that allows you to create and execute action lists"
+pkgrel=3
+pkgdesc='A task automation tool that allows you to create and execute action lists'
arch=('x86_64')
-url="https://wiki.actiona.tools"
+url='https://wiki.actiona.tools'
license=('GPL3')
depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'libnotify' 'qt5-speech')
makedepends=('qt5-tools' 'boost' 'opencv')
source=("https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
sha256sums=('7f7a6ecef82ec51fc5d92e41a9d39d1de190135b1fb6293318feb1d88ceb8757'
- 'f359c8457947fb248d95bae8dd2dd59feaa01aa29b7b778963bc0dc1c7fd963f')
+ '92b1368978b1feb0620095a21b95737d93839ff4bf5f97ec2f1c2b2a1ab4f5ea')
prepare() {
cd "${srcdir}"
diff --git a/actiona.patch b/actiona.patch
index 854002d02948..b784f5d66798 100644
--- a/actiona.patch
+++ b/actiona.patch
@@ -1,6 +1,6 @@
diff -rupN actiona-3.10.0/actiona.pro actiona-3.10.0b/actiona.pro
--- actiona-3.10.0/actiona.pro 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiona.pro 2018-12-01 18:13:46.093993934 -0500
++++ actiona-3.10.0b/actiona.pro 2019-12-23 09:13:50.937843430 -0500
@@ -1,21 +1,6 @@
TEMPLATE = subdirs
CONFIG = ordered
@@ -25,7 +25,7 @@ diff -rupN actiona-3.10.0/actiona.pro actiona-3.10.0b/actiona.pro
contains(DEFINES, ACT_NO_UPDATER){
diff -rupN actiona-3.10.0/actiontools/actiontools.pro actiona-3.10.0b/actiontools/actiontools.pro
--- actiona-3.10.0/actiontools/actiontools.pro 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/actiontools.pro 2018-12-01 18:14:31.113647152 -0500
++++ actiona-3.10.0b/actiontools/actiontools.pro 2019-12-23 09:13:50.961176893 -0500
@@ -6,7 +6,7 @@ unix:QT += x11extras
TEMPLATE = lib
CONFIG += dll
@@ -35,9 +35,20 @@ diff -rupN actiona-3.10.0/actiontools/actiontools.pro actiona-3.10.0b/actiontool
DEFINES += ACTIONTOOLS_LIBRARY
TARGET = actiontools
DESTDIR = ..
+diff -rupN actiona-3.10.0/actiontools/keyboardkeyedit.cpp actiona-3.10.0b/actiontools/keyboardkeyedit.cpp
+--- actiona-3.10.0/actiontools/keyboardkeyedit.cpp 2018-07-17 14:29:12.000000000 -0400
++++ actiona-3.10.0b/actiontools/keyboardkeyedit.cpp 2019-12-23 09:13:50.957843541 -0500
+@@ -19,6 +19,7 @@
+ */
+
+ #include "keyboardkeyedit.h"
++#include <QKeyEvent>
+
+ namespace ActionTools
+ {
diff -rupN actiona-3.10.0/actiontools/opencvalgorithms.cpp actiona-3.10.0b/actiontools/opencvalgorithms.cpp
--- actiona-3.10.0/actiontools/opencvalgorithms.cpp 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/opencvalgorithms.cpp 2018-12-01 18:17:54.966178080 -0500
++++ actiona-3.10.0b/actiontools/opencvalgorithms.cpp 2019-12-23 09:13:50.947843486 -0500
@@ -350,7 +350,7 @@ namespace ActionTools
#if CV_MAJOR_VERSION == 2
@@ -90,7 +101,7 @@ diff -rupN actiona-3.10.0/actiontools/opencvalgorithms.cpp actiona-3.10.0b/actio
}
diff -rupN actiona-3.10.0/actiontools/opencvalgorithms_private.h actiona-3.10.0b/actiontools/opencvalgorithms_private.h
--- actiona-3.10.0/actiontools/opencvalgorithms_private.h 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/actiontools/opencvalgorithms_private.h 2018-12-01 18:18:40.094024935 -0500
++++ actiona-3.10.0b/actiontools/opencvalgorithms_private.h 2019-12-23 09:13:50.957843541 -0500
@@ -33,7 +33,7 @@ namespace cv
}
@@ -102,7 +113,7 @@ diff -rupN actiona-3.10.0/actiontools/opencvalgorithms_private.h actiona-3.10.0b
class UMat;
diff -rupN actiona-3.10.0/common.pri actiona-3.10.0b/common.pri
--- actiona-3.10.0/common.pri 2018-07-17 14:29:12.000000000 -0400
-+++ actiona-3.10.0b/common.pri 2018-12-01 18:20:22.893901846 -0500
++++ actiona-3.10.0b/common.pri 2019-12-23 09:13:50.937843430 -0500
@@ -11,6 +11,24 @@ if(!isEmpty(VERSION_OVERRIDE)) {
ACTIONA_VERSION = $$VERSION_OVERRIDE
}