summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2021-08-30 18:17:46 +0430
committerAmin Vakil2021-08-30 18:17:46 +0430
commitb5da860443e345e19a36cab842d275dadfbc60d6 (patch)
tree5dd89828ab797044791d7bda4d6737f33c8f4076
downloadaur-b5da860443e345e19a36cab842d275dadfbc60d6.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3e69f14d55a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = actionlint
+ pkgdesc = Static checker for GitHub Actions workflow files
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/rhysd/actionlint
+ arch = any
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = https://github.com/rhysd/actionlint/archive/refs/tags/v1.6.2.tar.gz
+ sha256sums = f7d12f0c8bd1bf00295cfd035ffe3c8196127897046ff32182bba67e8d368d60
+
+pkgname = actionlint
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a99e49df52cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Amin Vakil <info AT aminvakil DOT com>
+
+pkgname=actionlint
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Static checker for GitHub Actions workflow files"
+arch=('any')
+url="https://github.com/rhysd/actionlint"
+license=('MIT')
+makedepends=('go' 'git')
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('f7d12f0c8bd1bf00295cfd035ffe3c8196127897046ff32182bba67e8d368d60')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./cmd/${pkgname}
+}
+
+test() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}