summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParham Alvani2021-08-30 13:25:27 +0430
committerParham Alvani2021-08-30 13:25:27 +0430
commit5f5ca61a31b4efe42258f6a718299b991509488f (patch)
tree9b77098d923d427268f81f6b9756e43a4d893f41
downloadaur-5f5ca61a31b4efe42258f6a718299b991509488f.tar.gz
feat: add v1.6.2 of actionlint
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e812f852434
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = actionlint-bin
+ pkgdesc = Static checker for GitHub Actions workflow files
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/rhysd/actionlint
+ arch = x86_64
+ license = MIT
+ provides = actionlint
+ conflicts = actionlint
+ conflicts = actionlint-git
+ source = https://github.com/rhysd/actionlint/releases/download/v1.6.2/actionlint_1.6.2_linux_amd64.tar.gz
+ sha256sums = 6b27de7416d28507f1572f715f57acfaf5c68f2d84ea0f3a70a5f5f25cae68e0
+
+pkgname = actionlint-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fba5c2f25a6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Parham Alvani <parham.alvani@gmail.com>
+
+pkgname=actionlint-bin
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Static checker for GitHub Actions workflow files"
+arch=(x86_64)
+url="https://github.com/rhysd/actionlint"
+license=('MIT')
+
+conflicts=('actionlint' 'actionlint-git')
+provides=('actionlint')
+
+source=("https://github.com/rhysd/actionlint/releases/download/v${pkgver}/actionlint_${pkgver}_linux_amd64.tar.gz")
+
+sha256sums=('6b27de7416d28507f1572f715f57acfaf5c68f2d84ea0f3a70a5f5f25cae68e0')
+
+package() {
+ # package
+ install -D -m755 $srcdir/actionlint $pkgdir/usr/bin/actionlint
+}