summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPolis Minus2022-10-09 16:17:15 +0400
committerPolis Minus2022-10-09 16:17:15 +0400
commitee4746d2ded1c9eaea5a64967d90b01358d8c925 (patch)
tree64d9c84b978ca6249ff11d4d700cf8f506beadd5
parent89026c02bbf2985b71b3fe10ffa358447cc730fb (diff)
downloadaur-ee4746d2ded1c9eaea5a64967d90b01358d8c925.tar.gz
Updated to v1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c493e181d70..8a5a02dbd7fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = activate-linux
pkgdesc = The "Activate Windows" watermark ported to Linux with Xlib and cairo in C
- pkgver = 0.0.2
+ pkgver = 1.0.0
pkgrel = 2
url = https://github.com/MrGlockenspiel/activate-linux
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = activate-linux
depends = libxi
depends = libx11
depends = libxt
+ depends = wayland
+ depends = wayland-protocols
conflicts = activate-linux-git
- source = https://github.com/MrGlockenspiel/activate-linux/archive/refs/tags/v0.0.2.tar.gz
- sha512sums = 7ddbf3c1f9ee54b4d8e71c3bd8eaa823d83390ed9c6c915fc1d9f7abcab6472692465da9cede5171058be8160ab19ea41c4f8d119923f1595eb66d3247e96890
+ source = https://github.com/MrGlockenspiel/activate-linux/archive/refs/tags/v1.0.0.tar.gz
+ sha512sums = 1fc9a8d808742fc3e95ecc4886792748d3abab7a81a6e9df078e18c4f8d5e11588bee7f775496d0e54ebddc281e1afc4d37b075fec3247da011d12ac8dafe4ec
pkgname = activate-linux
diff --git a/PKGBUILD b/PKGBUILD
index 78febc0a3988..9698d3be4b7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Polis Minus <polisminus2247@tuta.io>
pkgname=activate-linux
-pkgver=0.0.2
+pkgver=1.0.0
_pkg="$pkgname-$pkgver"
pkgrel=2
pkgdesc="The \"Activate Windows\" watermark ported to Linux with Xlib and cairo in C"
@@ -8,20 +8,20 @@ arch=("x86_64")
url='https://github.com/MrGlockenspiel/activate-linux'
makedepends=('make' 'clang' 'pkgconf' 'libxfixes' 'libxinerama')
-depends=('cairo' 'libxi' 'libx11' 'libxt')
+depends=('cairo' 'libxi' 'libx11' 'libxt' 'wayland' 'wayland-protocols')
conflicts=('activate-linux-git')
license=('custom')
-sha512sums=('7ddbf3c1f9ee54b4d8e71c3bd8eaa823d83390ed9c6c915fc1d9f7abcab6472692465da9cede5171058be8160ab19ea41c4f8d119923f1595eb66d3247e96890')
+sha512sums=('1fc9a8d808742fc3e95ecc4886792748d3abab7a81a6e9df078e18c4f8d5e11588bee7f775496d0e54ebddc281e1afc4d37b075fec3247da011d12ac8dafe4ec')
-source=("https://github.com/MrGlockenspiel/activate-linux/archive/refs/tags/v0.0.2.tar.gz")
+source=("https://github.com/MrGlockenspiel/activate-linux/archive/refs/tags/v1.0.0.tar.gz")
build() {
- cd "$_pkg"
- make
+ cd "$srcdir/$_pkg/src"
+ make --silent --directory ..
}
package() {
- cd "$_pkg"
- install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $_pkg
+ install -Dm 644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D activate-linux "$pkgdir/usr/bin/activate-linux"
}