summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-05-13 19:04:53 +0200
committerjose17112016-05-13 19:04:53 +0200
commit6e61e5a91815adf429c4d07239247f338150097a (patch)
tree15cc8c163edf2a356cc68fceb775ec0e580dc253
downloadaur-6e61e5a91815adf429c4d07239247f338150097a.tar.gz
adopted from aur3
-rw-r--r--.SRCINFO22
-rw-r--r--10-promethean.conf12
-rw-r--r--PKGBUILD67
-rw-r--r--activdriver.install19
4 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e588a708705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri May 13 17:04:50 UTC 2016
+pkgbase = activdriver
+ pkgdesc = The kernel mode and X11 drivers for Promethean ActivBoard and ActivHub.
+ pkgver = 5.10.15
+ pkgrel = 4
+ url = http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release
+ install = activdriver.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = linux-headers
+ optdepends = activinspire: activboard presentation
+ optdepends = activtools: hardware calibration
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/oss/a/activdriver/activdriver_5.10.15-1~ubuntu~1204_.deb
+ source = 10-promethean.conf
+ source = activdriver.install
+ md5sums = 11effc25fd592acacb9f9f3108618963
+ md5sums = 8a8a6ddd6741a80a5839593ed385cd9a
+
+pkgname = activdriver
+
diff --git a/10-promethean.conf b/10-promethean.conf
new file mode 100644
index 000000000000..94184430279b
--- /dev/null
+++ b/10-promethean.conf
@@ -0,0 +1,12 @@
+Section "InputDevice"
+ Identifier "activpen"
+ Driver "promethean"
+ Option "Device" "/dev/input/activdevices"
+ Option "Type" "stylus"
+ Option "Mode" "Absolute"
+ Option "Cursor" "stylus"
+ Option "USB" "on"
+ Option "debuglevel" "5"
+ Option "Vendor" "promethean"
+ Option "SendCoreEvents" "true"
+EndSection
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af7caf9dd376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Bazon <bazonbloch@arcor.de>
+# Contributor: Christian Bühler <christian@cbuehler.de>
+# Contributor: Zsolt Udvari <udvzsolt@gmail.com>
+pkgname=activdriver
+pkgver=5.10.15
+pkgrel=4
+pkgdesc="The kernel mode and X11 drivers for Promethean ActivBoard and ActivHub."
+arch=('i686' 'x86_64')
+url="http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release"
+license=('unknown')
+makedepends=(linux-headers)
+optdepends=('activinspire: activboard presentation'
+ 'activtools: hardware calibration')
+install=$pkgname.install
+if [ "$CARCH" = "i686" ]; then
+ _arch='i386'
+ _md5sum='a90ae7a20d6704e2c2090136bb505c84'
+elif [ "$CARCH" = "x86_64" ]; then
+ _arch='amd64'
+ _md5sum='6263eb7993f45cef97d84a5fb9619a94'
+fi
+source=("http://activsoftware.co.uk/linux/repos/ubuntu/pool/oss/a/$pkgname/${pkgname}_$pkgver-1~ubuntu~1204_$_arch.deb"
+ "10-promethean.conf"
+ "activdriver.install")
+md5sums=( $_md5sum
+ '11effc25fd592acacb9f9f3108618963'
+ '8a8a6ddd6741a80a5839593ed385cd9a')
+
+
+build() {
+ tar xf data.tar.gz
+ echo " "
+ echo "Attention!"
+ echo "Build will fail if run in a directory with space(s) in its path."
+ #(reason: makefile of the source. if you know how to fix: please tell!)
+ echo " "
+ make -C /lib/modules/$(uname -r)/build SUBDIRS="$srcdir"/usr/src/promethean/kernel modules
+ sed -i "s%KERN_INC = /usr/src/promethean%KERN_INC = ..%" usr/src/promethean/activlc/Makefile
+ BUILD=release make -C usr/src/promethean/activlc
+ sed -i s%/usr/local/bin/%%g usr/bin/promethean.sh
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr
+ cp -r etc lib "$pkgdir"
+ cp -r usr/bin usr/lib usr/share "$pkgdir"/usr
+ install -D usr/src/promethean/activlc/release/activlc "$pkgdir"/usr/bin/activlc
+ _extmoddir=$(uname -r | sed "s@\([0-9]*\.[0-9]*\)\.[0-9]*-[0-9]*\(.*\)@\1\2@")
+
+ # changed compared to pkgrel=1: needs to be this path now:
+ _moddir="/usr/lib/modules/extramodules-${_extmoddir}"/kernel/drivers/input/tablet/
+
+ install -m644 -D usr/src/promethean/kernel/promethean.ko \
+ "$pkgdir${_moddir}"/promethean.ko
+ find "${pkgdir}" -name '*.ko' -exec gzip -9 {} \;
+ install -D 10-promethean.conf "$pkgdir"/etc/X11/xorg.conf.d/10-promethean.conf
+
+ # changed compared to pkgrel=1: move /lib to /usr/lib to match arch standards
+ mv "${pkgdir}"/lib/* "${pkgdir}"/usr/lib/
+ rmdir "${pkgdir}"/lib
+
+ # changed compared to pkgrel=1: load module on boot.
+ # If you don't want this, delete the following lines and load it manually with sudo modprobe promethean
+ mkdir -p "$pkgdir"/etc/modules-load.d
+ echo "promethean" > "$pkgdir"/etc/modules-load.d/promethean.conf
+}
diff --git a/activdriver.install b/activdriver.install
new file mode 100644
index 000000000000..660565214354
--- /dev/null
+++ b/activdriver.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo "finding module"
+ depmod
+ echo "inserting module"
+ modprobe promethean
+ echo " "
+ echo "If you don't want the promethean module to be loaded on boot, delete /etc/modules-load.d/promethean.conf or delete the matching lines in PKGBUILD and re-install."
+ echo " "
+}
+
+post_upgrade() {
+ echo "finding module"
+ depmod
+ echo "inserting module"
+ modprobe promethean
+ echo " "
+ echo "If you don't want the promethean module to be loaded on boot, delete /etc/modules-load.d/promethean.conf or delete the matching lines in PKGBUILD and re-install."
+ echo " "
+} \ No newline at end of file