summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalstrond2019-12-06 17:26:36 +0100
committerMalstrond2019-12-06 17:26:36 +0100
commit802f02cb6fe29b0818f38583f161030b6666a0a4 (patch)
treedbf9fc4ffb79e352afc33ce5647d1eca847a827c
parent3175b50dfbcda924da1fd8a84a9093aadba942d7 (diff)
downloadaur-802f02cb6fe29b0818f38583f161030b6666a0a4.tar.gz
Updated, some PKGBUILD cleanup
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ccb42b3afd..c3fbba31e1d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = activdriver
pkgdesc = Drivers for Promethean hardware
- pkgver = 5.18.12
- pkgrel = 1
+ pkgver = 5.18.18
+ pkgrel = 0
url = https://support.prometheanworld.com/product/activdriver
install = activdriver.install
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = activdriver
makedepends = linux-headers>=5.0.1.arch1-1
optdepends = activinspire: Prometheans presentation software
optdepends = activtools: Tools for Promethean hardware, e.g. calibration or systray monitor
- source_x86_64 = http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/oss/a/activdriver/activdriver_5.18.12-0~Ubuntu~1804_amd64.deb
- source_x86_64 = activdriver.install
- md5sums_x86_64 = d09c1be7e554f6682b1ad574ceb81ae8
- md5sums_x86_64 = 8a8a6ddd6741a80a5839593ed385cd9a
+ source = http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/oss/a/activdriver/activdriver_5.18.18-0~Ubuntu~1804_amd64.deb
+ source = activdriver.install
+ md5sums = cad12d9ea55b6df0344375a311e75659
+ md5sums = 8a8a6ddd6741a80a5839593ed385cd9a
pkgname = activdriver
diff --git a/PKGBUILD b/PKGBUILD
index 5a2e0fc84781..2775628405b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Malstrond <malstrond@gmail.com>
-# Contributor: Jose Riha <jose1711 gmail com>
+# Contributor: Jose Riha <jose1711@gmail.com>
# Contributor: Bazon <bazonbloch@arcor.de>
# Contributor: Christian Bühler <christian@cbuehler.de>
# Contributor: Zsolt Udvari <udvzsolt@gmail.com>
pkgname=activdriver
-pkgver=5.18.12
-pkgrel=1
+pkgver=5.18.18
+pkgrel=0
pkgdesc="Drivers for Promethean hardware"
arch=('x86_64')
url="https://support.prometheanworld.com/product/activdriver"
@@ -15,11 +15,11 @@ makedepends=('linux-headers>=5.0.1.arch1-1')
optdepends=('activinspire: Prometheans presentation software'
'activtools: Tools for Promethean hardware, e.g. calibration or systray monitor')
install=$pkgname.install
-source_x86_64=("http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/oss/a/$pkgname/${pkgname}_$pkgver-0~Ubuntu~1804_amd64.deb"
- "activdriver.install")
-md5sums_x86_64=('d09c1be7e554f6682b1ad574ceb81ae8'
- '8a8a6ddd6741a80a5839593ed385cd9a')
-
+source=("http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/oss/a/$pkgname/${pkgname}_$pkgver-0~Ubuntu~1804_amd64.deb"
+ "activdriver.install")
+md5sums=('cad12d9ea55b6df0344375a311e75659'
+ '8a8a6ddd6741a80a5839593ed385cd9a')
+
prepare() {
# Extract the source
bsdtar -xf data.tar.xz
@@ -48,7 +48,7 @@ build() {
echo "Attention!"
echo "This build will fail if run in a directory with space(s) in its path due to an error in the upstream makefile."
echo " "
- make -C /lib/modules/$(uname -r)/build SUBDIRS="$srcdir"/usr/src/promethean/kernel modules
+ make -C /lib/modules/$(uname -r)/build M="$srcdir"/usr/src/promethean/kernel modules
BUILD=release make -C usr/src/promethean/activlc
}