summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-05-13 14:09:42 +0200
committerjose17112016-05-13 14:09:42 +0200
commit83580e7776c8a9be75fedadbf5177dc6e8dfba83 (patch)
treef73bf917e285aee23afe2dc8b5a8d1805fab0899
downloadaur-83580e7776c8a9be75fedadbf5177dc6e8dfba83.tar.gz
adopted from aur3
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b96fbe32afc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri May 13 12:09:38 UTC 2016
+pkgbase = activinspire
+ pkgdesc = Presentation Software to use with Promethean Hardware products.
+ pkgver = 2.3.65940
+ pkgrel = 3
+ url = http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = qt4
+ depends = gstreamer0.10-good-plugins
+ depends = bin32-jre
+ depends = lib32-libjpeg
+ depends = lib32-libjpeg6
+ depends = lib32-libxmu
+ depends = lib32-gstreamer0.10-base
+ depends = lib32-alsa-lib
+ depends = lib32-openssl098
+ depends = lib32-libpulse
+ optdepends = activdriver: promethean hardware support
+ optdepends = activtools: hardware calibration
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.3.65940-1.amd64_amd64.deb
+ md5sums = 3b5ada7a4a713d2e3b0d4547530f2919
+
+pkgname = activinspire
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fcabd8e55a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Bazon <bazonbloch@arcor.de>
+pkgname=activinspire
+pkgver=2.3.65940
+pkgrel=3
+pkgdesc="Presentation Software to use with Promethean Hardware products."
+arch=('i686' 'x86_64')
+url="http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release"
+license=('unknown')
+if [ "$CARCH" = "i686" ]; then
+ _arch='i386'
+ _md5sum='faed7e0ca0f04190df6702ebc18c7489'
+ depends=('qt4' 'gstreamer0.10-good-plugins' 'libjpeg6' 'jre7-openjdk' 'openssl098' 'libpulse')
+else
+ _arch='amd64'
+ _md5sum='3b5ada7a4a713d2e3b0d4547530f2919'
+ depends=('qt4' 'gstreamer0.10-good-plugins' 'bin32-jre' 'lib32-libjpeg' 'lib32-libjpeg6' 'lib32-libxmu' 'lib32-gstreamer0.10-base' 'lib32-alsa-lib' 'lib32-openssl098' 'lib32-libpulse')
+fi
+optdepends=('activdriver: promethean hardware support'
+ 'activtools: hardware calibration')
+source=(http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_$pkgver-1."$_arch"_"$_arch".deb)
+md5sums=( $_md5sum )
+package() {
+ # extract the archive
+ bsdtar -xf data.tar.gz -C "$pkgdir"
+
+ # move out of the local directory to match arch standards
+ mv "$pkgdir"/usr/local/bin "$pkgdir"/usr/
+ rmdir "$pkgdir"/usr/local
+
+ # the included libphonon_gstreamer.so makes inspire crash on64bit, so take a link to a working one instead
+ if [ "$CARCH" = "x86_64" ]; then
+ rm "$pkgdir"/usr/bin/activsoftware/phonon_backend/libphonon_gstreamer.so
+ ln -s /usr/lib/libphonon.so "$pkgdir"/usr/bin/activsoftware/phonon_backend/libphonon_gstreamer.so
+ fi
+
+ # the starting script contains a lot of stuff specific to ubuntu, we don't need that and make a shorter one
+ mv "$pkgdir"/usr/bin/inspire "$pkgdir"/usr/bin/inspire-for-ubuntu
+ echo "#! /bin/bash" > "$pkgdir"/usr/bin/inspire
+ # in order to make java work, we need an export for 64bit versions:
+ if [ "$CARCH" = "x86_64" ]; then
+ echo "export JAVA_HOME=/usr/lib32/jvm/java32-8-jre/jre/" >> "$pkgdir"/usr/bin/inspire
+ fi
+ echo "cd /usr/bin/activsoftware" >> "$pkgdir"/usr/bin/inspire
+ echo "./Inspire \$1" >> "$pkgdir"/usr/bin/inspire
+ chmod 755 "$pkgdir"/usr/bin/inspire
+
+ # delete the no-compiz-shortcut. if you want it, delete the following line
+ rm "$pkgdir"/usr/share/applications/activsoftware-nc.desktop
+
+ # modify the other one to match the new path and add a better hires icon
+ install -Dm644 "$pkgdir/usr/bin/activsoftware/inspire.ico" "$pkgdir/usr/share/icons/hicolor/512x512/apps/inspire.ico"
+ sed -i 's/48x48\/apps\/asstudio.png/512x512\/apps\/inspire.ico/' "$pkgdir"/usr/share/applications/activsoftware.desktop
+ sed -i 's/usr\/local\/bin/usr\/bin/' "$pkgdir"/usr/share/applications/activsoftware.desktop
+}