summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-09-28 22:59:50 +0200
committerjose17112017-09-28 22:59:50 +0200
commita32cf309f8fe3df1ab5ee0494567c489700ea259 (patch)
tree5a32a83a3a40d48d58ef66940099a078edf42fea
parent83580e7776c8a9be75fedadbf5177dc6e8dfba83 (diff)
downloadaur-a32cf309f8fe3df1ab5ee0494567c489700ea259.tar.gz
Fix and update
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD42
2 files changed, 42 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b96fbe32afc..4a8b07dc90b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
# Generated by mksrcinfo v8
-# Fri May 13 12:09:38 UTC 2016
+# Thu Sep 28 20:59:47 UTC 2017
pkgbase = activinspire
pkgdesc = Presentation Software to use with Promethean Hardware products.
- pkgver = 2.3.65940
- pkgrel = 3
- url = http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release
+ pkgver = 2.10.66827
+ pkgrel = 1
+ url = https://support.prometheanworld.com/product/activinspire
arch = i686
arch = x86_64
license = unknown
- depends = qt4
- depends = gstreamer0.10-good-plugins
- depends = bin32-jre
- depends = lib32-libjpeg
- depends = lib32-libjpeg6
- depends = lib32-libxmu
- depends = lib32-gstreamer0.10-base
- depends = lib32-alsa-lib
- depends = lib32-openssl098
- depends = lib32-libpulse
- optdepends = activdriver: promethean hardware support
- optdepends = activtools: hardware calibration
- source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.3.65940-1.amd64_amd64.deb
- md5sums = 3b5ada7a4a713d2e3b0d4547530f2919
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.10.66827-1.amd64_amd64.deb
+ depends_i686 = qt4
+ depends_i686 = gst-plugins-base
+ depends_i686 = libjpeg6
+ depends_i686 = jre7-openjdk
+ depends_i686 = openssl-1.0
+ depends_i686 = libpulse
+ depends_x86_64 = qt4
+ depends_x86_64 = lib32-gst-plugins-base
+ depends_x86_64 = bin32-jre
+ depends_x86_64 = lib32-libjpeg
+ depends_x86_64 = lib32-libjpeg6
+ depends_x86_64 = lib32-libxmu
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-openssl-1.0
+ depends_x86_64 = lib32-libpulse
pkgname = activinspire
diff --git a/PKGBUILD b/PKGBUILD
index 0fcabd8e55a9..cb7b46106496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
# Maintainer: Jose Riha <jose1711 gmail com>
# Contributor: Bazon <bazonbloch@arcor.de>
+
pkgname=activinspire
-pkgver=2.3.65940
-pkgrel=3
+pkgver=2.10.66827
+pkgrel=1
pkgdesc="Presentation Software to use with Promethean Hardware products."
arch=('i686' 'x86_64')
-url="http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release"
+url="https://support.prometheanworld.com/product/activinspire"
license=('unknown')
-if [ "$CARCH" = "i686" ]; then
- _arch='i386'
- _md5sum='faed7e0ca0f04190df6702ebc18c7489'
- depends=('qt4' 'gstreamer0.10-good-plugins' 'libjpeg6' 'jre7-openjdk' 'openssl098' 'libpulse')
+depends_i686=('qt4' 'gst-plugins-base' 'libjpeg6' 'jre7-openjdk' 'openssl-1.0' 'libpulse')
+depends_x86_64=('qt4' 'lib32-gst-plugins-base' 'bin32-jre' 'lib32-libjpeg' 'lib32-libjpeg6' 'lib32-libxmu' 'lib32-alsa-lib' 'lib32-openssl-1.0' 'lib32-libpulse')
+md5sum_i686='08044e50534527a7a88ac6ff0586c934'
+md5sum_x86_64='59b14c0463a4f11c5e9cacd4d7206fae'
+if [ ${CARCH} = "i686" ]
+then
+ _arch="i386"
else
- _arch='amd64'
- _md5sum='3b5ada7a4a713d2e3b0d4547530f2919'
- depends=('qt4' 'gstreamer0.10-good-plugins' 'bin32-jre' 'lib32-libjpeg' 'lib32-libjpeg6' 'lib32-libxmu' 'lib32-gstreamer0.10-base' 'lib32-alsa-lib' 'lib32-openssl098' 'lib32-libpulse')
+ _arch="amd64"
fi
-optdepends=('activdriver: promethean hardware support'
- 'activtools: hardware calibration')
-source=(http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_$pkgver-1."$_arch"_"$_arch".deb)
-md5sums=( $_md5sum )
+
+_u="http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/"
+source=(
+ ${_u}activinspire/activinspire_${pkgver}-1."$_arch"_"$_arch".deb
+ )
+
+prepare() {
+ bsdtar -xf activinspire_${pkgver}-1.${_arch}_${_arch}.deb
+}
+
package() {
# extract the archive
bsdtar -xf data.tar.gz -C "$pkgdir"
@@ -28,12 +36,6 @@ package() {
mv "$pkgdir"/usr/local/bin "$pkgdir"/usr/
rmdir "$pkgdir"/usr/local
- # the included libphonon_gstreamer.so makes inspire crash on64bit, so take a link to a working one instead
- if [ "$CARCH" = "x86_64" ]; then
- rm "$pkgdir"/usr/bin/activsoftware/phonon_backend/libphonon_gstreamer.so
- ln -s /usr/lib/libphonon.so "$pkgdir"/usr/bin/activsoftware/phonon_backend/libphonon_gstreamer.so
- fi
-
# the starting script contains a lot of stuff specific to ubuntu, we don't need that and make a shorter one
mv "$pkgdir"/usr/bin/inspire "$pkgdir"/usr/bin/inspire-for-ubuntu
echo "#! /bin/bash" > "$pkgdir"/usr/bin/inspire