summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2020-07-17 01:41:16 +0200
committerHaochen Tong2020-07-17 01:41:16 +0200
commit62cd912fde64f98d414423147c7292cee628b3cd (patch)
treee6d34bb902a4a8ad1378ea53c20187c56a69c312
parentf4770e7197e26ab8d25f32afabcb44f432ea0479 (diff)
downloadaur-62cd912fde64f98d414423147c7292cee628b3cd.tar.gz
fix license and aw_core setup.py
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 554d25eed05e..fba3c80eb2b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = activitywatch
pkgrel = 1
url = https://activitywatch.net/
arch = x86_64
+ license = MPL2
makedepends = python-dephell
makedepends = npm
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 665d9e4a4953..ccb6c528706e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgname=activitywatch
pkgver=0.9.2
pkgrel=1
url="https://activitywatch.net/"
-licenses=("MPL2")
+license=("MPL2")
arch=('x86_64')
depends=(
'python' # obviously
@@ -42,7 +42,7 @@ prepare() {
cd "$srcdir/$pkgname"
git submodule init
- for submodule in aw-{client,core,qt,server,watcher-{afk,window}}; do
+ for submodule in aw-{core,client,qt,server,watcher-{afk,window}}; do
git config submodule.$submodule.url "$srcdir/${submodule##*/}"
done
git submodule update
@@ -76,6 +76,11 @@ prepare() {
dephell deps convert --from pyproject.toml --to setup.py
popd
done
+
+ pushd aw-core
+ sed -i "s/packages=\\['aw_core'\\]/packages=['aw_core', 'aw_datastore', 'aw_transform', 'aw_query']/" setup.py
+ popd
+
}
build() {