aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Bjäreholt2023-10-25 11:53:19 +0200
committerErik Bjäreholt2023-10-25 11:53:40 +0200
commit5567b12e274ccfef780f03750abbbc483827c276 (patch)
tree72505e60e7fb675e959012f98a4b7897f1d73e74
parent6ebb975497048f48a4c180991db656fa1cbdc4c2 (diff)
downloadaur-5567b12e274ccfef780f03750abbbc483827c276.tar.gz
added computing md5sums with updpkgsums (fixes https://github.com/ActivityWatch/aur-activitywatch-bin/issues/9)
Co-authored-by: Asuka Minato <i@asukaminato.eu.org>
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD4
-rw-r--r--README.md12
4 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b17cf9b0963..4f2fd4600a10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = activitywatch-bin
pkgdesc = Log what you do on your computer. Simple, extensible, no third parties.
pkgver = 0.12.3b12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ActivityWatch/activitywatch
arch = x86_64
license = MPL2
provides = activitywatch
conflicts = activitywatch
source = https://github.com/ActivityWatch/activitywatch/releases/download/v0.12.3b12/activitywatch-v0.12.3b12-linux-x86_64.zip
- md5sums = SKIP
+ md5sums = 74f605bf34f9f352261ca9a53cc32082
pkgname = activitywatch-bin
diff --git a/Makefile b/Makefile
index a8ca4b41934a..244934cd873d 100644
--- a/Makefile
+++ b/Makefile
@@ -4,10 +4,8 @@ package: .SRCINFO
install:
makepkg -i
-srcinfo: .SRCINFO
-
-.SRCINFO: PKGBUILD
- makepkg --printsrcinfo > .SRCINFO
+check:
+ namcap *.pkg.*
update: .SRCINFO
git add PKGBUILD .SRCINFO
@@ -17,3 +15,7 @@ update: .SRCINFO
clean:
rm -rf pkg src *.pkg.tar.*
+
+.SRCINFO: PKGBUILD
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 0589fc7228da..f4f0875f0481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=activitywatch-bin
pkgver='0.12.3b12'
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Log what you do on your computer. Simple, extensible, no third parties."
arch=('x86_64')
@@ -20,7 +20,7 @@ depends=(
#'openssl-1.0'
)
source=("https://github.com/ActivityWatch/activitywatch/releases/download/v${pkgver}/activitywatch-v${pkgver}-linux-x86_64.zip")
-md5sums=('SKIP')
+md5sums=('74f605bf34f9f352261ca9a53cc32082')
package() {
# Install into /opt/activitywatch
diff --git a/README.md b/README.md
index e90a2bbdaef9..7607d44ed6c8 100644
--- a/README.md
+++ b/README.md
@@ -10,11 +10,15 @@ You need:
- Maintainer rights to the AUR package
- Your AUR ssh key configured
-After checking that the package builds correctly (using `make package`) simply run:
-
+After modifying `PKGBUILD` as appropriate, and testing the package on your machine, run the following to:
+ - build the package
+ - updates checksums with `updpkgsums`
+ - regenerates `.SRCINFO` with `makepkg --printsrcinfo > .SRCINFO`
+ - commit the changes
+ - push to the AUR
```sh
-make srcinfo
-git add srcinfo
+make package
+git add PKGBUILD .SRCINFO
git commit -m "Updated .SRCINFO"
git remote add aur aur@aur.archlinux.org/activitywatch-bin.git
git push aur