aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Bjäreholt2018-02-26 18:36:07 +0100
committerErik Bjäreholt2018-02-26 18:37:16 +0100
commit88d8f9cd365b819b8ebc61cc403ba2cfd2b63f6e (patch)
treecf9ba0d81f8f211f9d893c33b4987105dcebc4f1
downloadaur-88d8f9cd365b819b8ebc61cc403ba2cfd2b63f6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8c88fb2518e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = activitywatch-bin
+ pkgdesc = Log what you do on your computer. Simple, extensible, no third parties.
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/ActivityWatch/activitywatch
+ arch = x86_64
+ license = MPL2
+ provides = activitywatch
+ conflicts = activitywatch
+ source = https://github.com/ActivityWatch/activitywatch/releases/download/v0.7.1/activitywatch-v0.7.1-linux-x86_64.zip
+ md5sums = SKIP
+
+pkgname = activitywatch-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4db5500074f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Erik Bjäreholt <erik.bjareholt@gmail.com>
+
+pkgname=activitywatch-bin
+pkgver='0.7.1'
+pkgrel=1
+epoch=
+pkgdesc="Log what you do on your computer. Simple, extensible, no third parties."
+arch=('x86_64')
+url="https://github.com/ActivityWatch/activitywatch"
+license=('MPL2')
+provides=("activitywatch")
+conflicts=("activitywatch")
+source=("https://github.com/ActivityWatch/activitywatch/releases/download/v${pkgver}/activitywatch-v${pkgver}-linux-x86_64.zip")
+md5sums=('SKIP')
+
+package() {
+ # Install into /opt/activitywatch
+ mkdir -p $pkgdir/opt
+ cp -r activitywatch $pkgdir/opt
+
+ # Symlink executables to /usr/bin
+ mkdir -p $pkgdir/usr/bin
+ execnames=("aw-server" "aw-watcher-afk" "aw-watcher-window" "aw-qt")
+ for execname in $execnames; do
+ ln -s /opt/activitywatch/$execname $pkgdir/usr/bin/$execname
+ done
+}