summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-09-29 00:42:09 +0200
committerjose17112017-09-29 00:42:09 +0200
commit7919235448bf53ba89b0b4ac9a9374633f220e52 (patch)
tree7d4ebdd09a7a083f2cbd822e01732b3464b3535b
downloadaur-activrelay.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0abb55ff5239
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Sep 28 22:42:03 UTC 2017
+pkgbase = activrelay
+ pkgdesc = Enables the use of Promethean hardware with ClassFlow
+ pkgver = 3.4.2
+ pkgrel = 1
+ url = https://support.prometheanworld.com/product/activdriver
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = qt4
+ optdepends = activinspire: activboard presentation
+ source_i686 = http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/non-oss/a/activrelay/activrelay_3.4.2-0~Ubuntu~1604_i386.deb
+ md5sums_i686 = ed0b1f8f5163c2569aa29d829d117764
+ source_x86_64 = http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/non-oss/a/activrelay/activrelay_3.4.2-0~Ubuntu~1604_amd64.deb
+ md5sums_x86_64 = 8aea84ea603ea249719dd4c75fed5929
+
+pkgname = activrelay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..576dcf145de0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=activrelay
+pkgver=3.4.2
+pkgrel=1
+pkgdesc="Enables the use of Promethean hardware with ClassFlow"
+arch=('i686' 'x86_64')
+url="https://support.prometheanworld.com/product/activdriver"
+license=('unknown')
+depends=('qt4')
+
+optdepends=('activinspire: activboard presentation')
+source_x86_64=(http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/non-oss/a/activrelay/activrelay_${pkgver}-0~Ubuntu~1604_amd64.deb)
+source_i686=(http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/non-oss/a/activrelay/activrelay_${pkgver}-0~Ubuntu~1604_i386.deb)
+md5sums_x86_64=('8aea84ea603ea249719dd4c75fed5929')
+md5sums_i686=('ed0b1f8f5163c2569aa29d829d117764')
+
+package() {
+ # extract archive
+ bsdtar -C "$pkgdir" -xf data.tar.xz
+
+ # move out of the local directory to match arch standards
+ mv "$pkgdir"/usr/local/* "$pkgdir"/usr/
+ rmdir "$pkgdir"/usr/local
+
+ # delete the following line if you want an autostart of activrelay
+ cd "$pkgdir"
+ rm -r etc
+}