summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Röthke2019-07-27 11:07:31 +0200
committerMarcel Röthke2019-07-27 12:16:05 +0200
commit9fda9edc482dad1884590dd8e9ab219baf9ffa5a (patch)
tree09305c0097604ca3c8955689bfda471be890ad0e
parent066cd0dccc962929822ac5eac382332b2bfc1db9 (diff)
downloadaur-9fda9edc482dad1884590dd8e9ab219baf9ffa5a.tar.gz
upgpkg: actor-framework 0.17.0-1
upstream release
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ab811464a4a..ea71b4d1d294 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = actor-framework
pkgdesc = An Open Source Implementation of the Actor Model in C++
- pkgver = 0.16.3
+ pkgver = 0.17.0
pkgrel = 1
url = http://actor-framework.org
arch = i686
@@ -12,12 +12,11 @@ pkgbase = actor-framework
makedepends = git
makedepends = python
makedepends = opencl-icd-loader
- makedepends = chrpath
optdepends = python: caf-python
optdepends = ipython: caf-python
optdepends = opencl-icd-loader: opencl support
optdepends = openssl: openssl support
- source = git+https://github.com/actor-framework/actor-framework#commit=903f801cc479a1dcbc9cc7a0ebdf5f920b981f0c
+ source = git+https://github.com/actor-framework/actor-framework#commit=af6de514d17b720286c85aab52a0c25f429ea893
source = git+https://github.com/pybind/pybind11.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index be931440338f..6572e9f22d88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Mirco Tischler <mt-ml at gmx dot de>
pkgname=actor-framework
-pkgver=0.16.3
+pkgver=0.17.0
pkgrel=1
pkgdesc="An Open Source Implementation of the Actor Model in C++"
arch=(i686 x86_64)
@@ -10,7 +10,7 @@ url="http://actor-framework.org"
license=('custom:"BSD-3-Clause"'
'custom:"Boost Software License"')
depends=()
-makedepends=('cmake' 'opencl-headers' 'git' 'python' 'opencl-icd-loader' 'chrpath')
+makedepends=('cmake' 'opencl-headers' 'git' 'python' 'opencl-icd-loader')
optdepends=(
'python: caf-python'
'ipython: caf-python'
@@ -19,7 +19,7 @@ optdepends=(
)
source=(
- "git+https://github.com/actor-framework/actor-framework#commit=903f801cc479a1dcbc9cc7a0ebdf5f920b981f0c"
+ "git+https://github.com/actor-framework/actor-framework#commit=af6de514d17b720286c85aab52a0c25f429ea893"
"git+https://github.com/pybind/pybind11.git"
)
sha256sums=(
@@ -44,20 +44,20 @@ prepare(){
}
build() {
- cd ${pkgname}
+ cd ${pkgname}/build
make
}
check() {
- cd ${pkgname}
+ cd ${pkgname}/build
make test
}
package() {
- cd ${pkgname}
+ cd ${pkgname}/build
make DESTDIR="${pkgdir}" install
+
+ cd ..
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 LICENSE_ALTERNATIVE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_ALTERNATIVE"
-
- chrpath -d "${pkgdir}/usr/bin/caf-python"
}