summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-12-07 16:40:10 +0100
committeraksr2015-12-07 16:40:10 +0100
commit07e4fa9e7bd0eccb205ad1cacccc27a8f27e8b9b (patch)
treedc82a8f2f59ccb0bfc34b4a78d360a26780145c4
downloadaur-07e4fa9e7bd0eccb205ad1cacccc27a8f27e8b9b.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3eec6649f2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Dec 7 15:40:10 UTC 2015
+pkgbase = ad-git
+ pkgdesc = ASCII file dump that can also search for and highlight strings or numbers.
+ pkgver = r229.56a366e
+ pkgrel = 1
+ url = https://github.com/paul-j-lucas/ad
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = ad
+ conflicts = ad
+ source = ad-git::git+https://github.com/paul-j-lucas/ad.git
+ md5sums = SKIP
+
+pkgname = ad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dc2dd221c67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=ad-git
+pkgver=r229.56a366e
+pkgrel=1
+epoch=
+pkgdesc="ASCII file dump that can also search for and highlight strings or numbers. "
+arch=('i686' 'x86_64')
+url="https://github.com/paul-j-lucas/ad"
+license=('GPL')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=('ad')
+conflicts=('ad')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/paul-j-lucas/ad.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ autoreconf -fiv
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+