summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkbipinkumar2023-02-01 14:46:28 +0530
committerkbipinkumar2023-02-01 14:46:28 +0530
commit700b05b5a5fac97bb426f00b0a976114b811bf77 (patch)
tree0d03eba98696a0c747cbb43729cd55e0c19672bb
downloadaur-700b05b5a5fac97bb426f00b0a976114b811bf77.tar.gz
ad2vcf: vesion 0.1.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddcfdc788b81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ad2vcf
+ pkgdesc = Tool to add allelic depth info from a SAM stream to a VCF file
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/auerlab/ad2vcf
+ arch = x86_64
+ license = BSD-2
+ depends = biolibc
+ source = ad2vcf-0.1.6.tar.gz::https://github.com/auerlab/ad2vcf/archive/refs/tags/0.1.6.tar.gz
+ sha256sums = fbed1e32504dbc6975cb124792d12e48576ed799ac148aa3b6beed33a67bdf98
+
+pkgname = ad2vcf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..727b57a1d780
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Bipin Kumar <bipin@ccmb.res.in>
+
+pkgname=ad2vcf
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="Tool to add allelic depth info from a SAM stream to a VCF file"
+arch=('x86_64')
+url="https://github.com/auerlab/ad2vcf"
+license=('BSD-2')
+depends=('biolibc')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/auerlab/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('fbed1e32504dbc6975cb124792d12e48576ed799ac148aa3b6beed33a67bdf98')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make PREFIX="$pkgdir/usr" clean depend
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr" MANPREFIX="$pkgdir/usr/share" clean depend install
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}