summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-10-12 06:15:24 +1100
committerRod Kay2021-10-12 06:16:32 +1100
commit625b18ee5b6d29f2df61a12fdafab06d8b5e0783 (patch)
treeed396203042095b2cfc9f15715decec4219e8c15
parent2ad8ca9ea0a7dedcfec5cec5780814451b3ca006 (diff)
downloadaur-625b18ee5b6d29f2df61a12fdafab06d8b5e0783.tar.gz
Update to 2021.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD88
-rw-r--r--aws-net-acceptors.adb-patch21
-rw-r--r--aws-server-hotplug.adb-patch12
-rw-r--r--aws-server.adb-patch12
5 files changed, 65 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6069c4adf6a..3db05cdd8b9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = ada-web-server
- pkgdesc = A complete embeddable Web application framework for Ada.
- pkgver = 2020
- pkgrel = 2
+ pkgdesc = A complete embeddable web application framework for Ada.
+ pkgver = 2021
+ pkgrel = 1
url = http://libre.adacore.com/tools/aws
arch = i686
arch = x86_64
groups = gcc-ada
license = GPL
+ makedepends = git
makedepends = gprbuild
makedepends = texlive-bin
+ makedepends = python-sphinx
depends = gcc-ada
provides = aws
- source = https://community.download.adacore.com/v1/61134515bc9fc53a3ccc6c6f0097cb95e2b0722e?filename=aws-20.0w-20190801-155D3-src.tar.gz
- source = aws-net-acceptors.adb-patch
- source = aws-server.adb-patch
- source = aws-server-hotplug.adb-patch
- sha1sums = 61134515bc9fc53a3ccc6c6f0097cb95e2b0722e
- sha1sums = e67c1264c9e4d03b5aa793edca97eb98b6fd813c
- sha1sums = ad5d8f554910747598325bdf4d8171bc03b1c6f3
- sha1sums = 01b054021747ba83f3e69e78b71b2a59c074bb06
+ source = git+https://github.com/AdaCore/aws#commit=5ddd74408d86363411714957baad72be76012b35
+ source = git+https://github.com/AdaCore/templates-parser#commit=2ed90c02deb53d5e453e62a4105354a9497c9ecd
+ sha1sums = SKIP
+ sha1sums = SKIP
pkgname = ada-web-server
-
diff --git a/PKGBUILD b/PKGBUILD
index 0cebf204bbd0..571ca779778d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,85 @@
-# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+# Maintainer: Rod Kay <rodakay5 at gmail dot com>
pkgname=ada-web-server
-pkgver=2020
-pkgrel=2
-pkgdesc="A complete embeddable Web application framework for Ada."
+pkgver=2021
+pkgrel=1
+pkgdesc="A complete embeddable web application framework for Ada."
arch=(i686 x86_64)
url=http://libre.adacore.com/tools/aws
license=(GPL)
groups=(gcc-ada)
-depends=('gcc-ada')
-makedepends=(gprbuild texlive-bin)
+depends=(gcc-ada)
+makedepends=(git gprbuild texlive-bin python-sphinx)
provides=(aws)
-source=('https://community.download.adacore.com/v1/61134515bc9fc53a3ccc6c6f0097cb95e2b0722e?filename=aws-20.0w-20190801-155D3-src.tar.gz'
- 'aws-net-acceptors.adb-patch'
- 'aws-server.adb-patch'
- 'aws-server-hotplug.adb-patch')
-sha1sums=('61134515bc9fc53a3ccc6c6f0097cb95e2b0722e'
- 'e67c1264c9e4d03b5aa793edca97eb98b6fd813c'
- 'ad5d8f554910747598325bdf4d8171bc03b1c6f3'
- '01b054021747ba83f3e69e78b71b2a59c074bb06')
+source=('git+https://github.com/AdaCore/aws#commit=5ddd74408d86363411714957baad72be76012b35'
+ 'git+https://github.com/AdaCore/templates-parser#commit=2ed90c02deb53d5e453e62a4105354a9497c9ecd')
+sha1sums=('SKIP'
+ 'SKIP')
prepare()
{
- cd $srcdir/aws-20.0w-20190801-155D3-src
-
- patch -p1 < "$srcdir/aws-net-acceptors.adb-patch"
- patch -p1 < "$srcdir/aws-server.adb-patch"
- patch -p1 < "$srcdir/aws-server-hotplug.adb-patch"
+ cd $srcdir/aws
+
+ rmdir templates_parser
+ ln -s "$srcdir/templates-parser" templates_parser
}
build()
{
- cd $srcdir/aws-20.0w-20190801-155D3-src
+ cd $srcdir/aws/templates_parser
- export BUILD_MODE=prod
- export LIBRARY_TYPE=static
- export LIBADALANG_LIBRARY_TYPE=relocatable
- export LANGKIT_SUPPORT_LIBRARY_TYPE=relocatable
- export BUILD=relocatable
-
- make setup
- make build
+ make DEBUG=false prefix=/usr setup
+ make -j1 DEBUG=false build
cd docs
- make SPHINXBUILD=sphinx-build2 html
+ mkdir -p build
+ make -j1 html latexpdf
+
+
+ cd $srcdir/aws
+
+ make prefix=/usr setup
+ make -j1 build
+
+ cd $srcdir/aws/docs
+ make -j1 html latexpdf
}
package()
{
- cd $srcdir/aws-20.0w-20190801-155D3-src
+ cd $srcdir/aws/templates_parser
+ make -j1 DEBUG=false DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" install
-}
+ cd $srcdir/aws
+ make -j1 DESTDIR="$pkgdir" install
+
+
+ # Install the license.
+ install -D -m644 \
+ "COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
+
+
+ # Install the templates-parser license.
+ install -D -m644 \
+ "COPYING3" \
+ "$pkgdir/usr/share/licenses/templates-parser/COPYING3"
+
+ # Install the templates-parser custom license.
+ install -D -m644 \
+ "COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/templates-parser/COPYING.RUNTIME"
+
+} \ No newline at end of file
diff --git a/aws-net-acceptors.adb-patch b/aws-net-acceptors.adb-patch
deleted file mode 100644
index 4bbcb2bb10c8..000000000000
--- a/aws-net-acceptors.adb-patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- aws-20.0w-20190801-155D3-src/src/core/aws-net-acceptors.adb 2019-07-31 10:33:51.000000000 +1000
-+++ aws-20.0w-20190801-155D3-src-new/src/core/aws-net-acceptors.adb 2020-10-13 17:01:58.799122021 +1100
-@@ -507,7 +507,7 @@
-
- procedure Add (S : not null access Socket_Type'Class) is
- begin
-- Sockets.Append (S);
-+ Sockets.Append (Socket_Access (S));
- end Add;
-
- -----------
-@@ -647,7 +647,7 @@
- and then Acceptor.W_Signal /= null;
-
- if Success then
-- Buffer.Append (S);
-+ Buffer.Append (Socket_Access (S));
- Acceptor.W_Signal.Send ((1 => Socket_Command));
- end if;
- end Add;
-
diff --git a/aws-server-hotplug.adb-patch b/aws-server-hotplug.adb-patch
deleted file mode 100644
index 1b4c87f0640f..000000000000
--- a/aws-server-hotplug.adb-patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- aws-20.0w-20190801-155D3-src/src/extended/aws-server-hotplug.adb 2019-07-31 10:33:51.000000000 +1000
-+++ aws-20.0w-20190801-155D3-src-new/src/extended/aws-server-hotplug.adb 2020-10-13 16:56:42.419559066 +1100
-@@ -120,7 +120,7 @@
- Line : String_Split.Slice_Set;
- N : Natural := 0;
- begin
-- Hotplug_Server.Start (Port, Web_Server, Host => Host);
-+ Hotplug_Server.Start (Port, HTTP_Access (Web_Server), Host => Host);
- AWS.Hotplug.Set_Mode (Web_Server.Filters, Register_Mode);
-
- Text_IO.Open (File, Text_IO.In_File, Authorization_File);
-
diff --git a/aws-server.adb-patch b/aws-server.adb-patch
deleted file mode 100644
index 094806bde53a..000000000000
--- a/aws-server.adb-patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- aws-20.0w-20190801-155D3-src/src/core/aws-server.adb 2019-07-31 10:33:51.000000000 +1000
-+++ aws-20.0w-20190801-155D3-src-new/src/core/aws-server.adb 2020-10-13 17:03:03.231072335 +1100
-@@ -898,7 +898,7 @@
- begin
- pragma Assert (Count > 0);
-
-- Table (Index).Sock := Socket;
-+ Table (Index).Sock := Socket_Access (Socket);
- Table (Index).Alive_Counter := 0;
- Table (Index).Alive_Time_Stamp := Ada.Calendar.Clock;
- Table (Index).Activity_Counter := Table (Index).Activity_Counter + 1;
-