summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2021-05-27 11:25:09 -0700
committerTim Lagnese2021-09-28 23:30:44 -0700
commit923baecaf8dfad763bdd84ce9df17245ea856b88 (patch)
treec9714ccd198e9b38773f014c696ed200fa0d2028
parent431c4f0203d6e1b83394e7c151127df35dfa0948 (diff)
downloadaur-923baecaf8dfad763bdd84ce9df17245ea856b88.tar.gz
Update to 22.0.7
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
-rw-r--r--VSS.patch8
3 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 862b42616a7d..6f4a8bab6afe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ada_language_server
pkgdesc = High performance syntactic and semantic engine for the Ada programming language
- pkgver = 22.0.6
+ pkgver = 22.0.7
pkgrel = 1
url = https://github.com/AdaCore/ada_language_server/
arch = x86_64
@@ -29,23 +29,23 @@ pkgbase = ada_language_server
conflicts = ada_language_server-git
conflicts = libvss
conflicts = libadalang
- source = ada_language_server-22.0.6.tar.gz::https://github.com/AdaCore/ada_language_server/archive/22.0.6.tar.gz
- source = git+https://github.com/AdaCore/VSS.git#commit=d6c6024
- source = git+https://github.com/AdaCore/langkit.git#commit=80d6e2c
- source = git+https://github.com/AdaCore/libadalang.git#commit=56616cc
- source = git+https://github.com/AdaCore/libadalang-tools.git#commit=479382d
- source = git+https://github.com/AdaCore/spawn.git#commit=e57c59d
+ source = ada_language_server-22.0.7.tar.gz::https://github.com/AdaCore/ada_language_server/archive/22.0.7.tar.gz
+ source = git+https://github.com/AdaCore/VSS.git#commit=d7dcb28
+ source = git+https://github.com/AdaCore/langkit.git#commit=5d83c8b
+ source = git+https://github.com/AdaCore/libadalang.git#commit=9e2bf8b
+ source = git+https://github.com/AdaCore/libadalang-tools.git#commit=34a8a64
+ source = git+https://github.com/AdaCore/spawn.git#commit=9cbd84e
source = libadalang-tools.patch
source = VSS.patch
source = ada_language_server.patch
- sha1sums = 14aa85d349d9b0837fb5295f92cfa8a130946afc
+ sha1sums = d56ba8b7bc207579ac9bf5f91a1d825986458ff8
sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
sha1sums = 1eb931d9aea713d3d553d9f6ebc44e5bce58f551
- sha1sums = dcc8be463ad852ea595748b5c3c092fc88f79ae5
+ sha1sums = aee366f733a0821034ac683745799d72f79b1941
sha1sums = ee3bc8ed18ef9f1c94361aa91acae4f6c1364a25
pkgname = ada_language_server
diff --git a/PKGBUILD b/PKGBUILD
index 54464456379e..f08604bf70cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tim Lagnese <tim at inept tech>
pkgname=ada_language_server
-pkgver=22.0.6
+pkgver=22.0.7
pkgrel=1
pkgdesc='High performance syntactic and semantic engine for the Ada programming language'
@@ -22,22 +22,22 @@ _pkgname=libadalang-tools
_pkgver=2020
_checksum=740372d8ffb1e4755a99bead2d78dace904235c0
source=("$pkgname-$pkgver.tar.gz::https://github.com/AdaCore/ada_language_server/archive/$pkgver.tar.gz"
- "git+https://github.com/AdaCore/VSS.git#commit=d6c6024"
- "git+https://github.com/AdaCore/langkit.git#commit=80d6e2c"
- "git+https://github.com/AdaCore/libadalang.git#commit=56616cc"
- "git+https://github.com/AdaCore/libadalang-tools.git#commit=479382d"
- "git+https://github.com/AdaCore/spawn.git#commit=e57c59d"
+ "git+https://github.com/AdaCore/VSS.git#commit=d7dcb28"
+ "git+https://github.com/AdaCore/langkit.git#commit=5d83c8b"
+ "git+https://github.com/AdaCore/libadalang.git#commit=9e2bf8b"
+ "git+https://github.com/AdaCore/libadalang-tools.git#commit=34a8a64"
+ "git+https://github.com/AdaCore/spawn.git#commit=9cbd84e"
"libadalang-tools.patch"
"VSS.patch"
"ada_language_server.patch")
-sha1sums=('14aa85d349d9b0837fb5295f92cfa8a130946afc'
+sha1sums=('d56ba8b7bc207579ac9bf5f91a1d825986458ff8'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'1eb931d9aea713d3d553d9f6ebc44e5bce58f551'
- 'dcc8be463ad852ea595748b5c3c092fc88f79ae5'
+ 'aee366f733a0821034ac683745799d72f79b1941'
'ee3bc8ed18ef9f1c94361aa91acae4f6c1364a25')
prepare() {
diff --git a/VSS.patch b/VSS.patch
index cf5f546a3c1e..3577ef8c89ce 100644
--- a/VSS.patch
+++ b/VSS.patch
@@ -2,12 +2,12 @@ Index: VSS/gnat/vss_config.gpr
===================================================================
--- VSS.orig/gnat/vss_config.gpr
+++ VSS/gnat/vss_config.gpr
-@@ -31,6 +31,8 @@ abstract project VSS_Config is
+@@ -34,6 +34,8 @@ abstract project VSS_Config is
Ada_Coverage_Switches := ();
Linker_Options := ();
+ for Library_Kind use "static-pic";
+
- case Build_Mode is
- when "prod" =>
- Ada_Switches := (
+ Object_Dir := "../.objs/" & Superproject;
+ Tests_Object_Dir := "../../.objs/" & Superproject & "/tests";
+