summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-07-08 15:05:31 +1000
committerRod Kay2021-07-08 15:05:31 +1000
commit9d911aea5019edcf9bc45d8de3ccd5b2dc2560fe (patch)
treec7e1aec587c415b508b9ba453e81bb8e0091e8af
parentae2e5b60d0c3611d1637bd79f45db1c7a27540ca (diff)
downloadaur-9d911aea5019edcf9bc45d8de3ccd5b2dc2560fe.tar.gz
Update to 2021 release.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD48
2 files changed, 34 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 129830a9d267..431ad8b0dace 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = ada_spawn
- pkgdesc = A simple Ada API to spawn processes and communicate with them.
- pkgver = r69.725a42d
+ pkgdesc = A simple Ada API to start processes and communicate with them.
+ pkgver = 21.0.0
pkgrel = 1
+ epoch = 1
url = https://github.com/AdaCore/spawn
+ arch = i686
arch = x86_64
license = GPL3
license = custom
- makedepends = git
- makedepends = gcc-ada
makedepends = gprbuild
- source = git+https://github.com/AdaCore/spawn.git#commit=725a42d9511ac414147dc9d7a2e16a6743e0f779
+ depends = gtkada
+ source = ada_spawn-21.0.0.tar.gz::https://community.download.adacore.com/v1/28342768afab1e644a660b96051c04e5e9d3bcb0?filename=ada_spawn-2021-20210701-19A43-src.tar.gz&rand=1809
source = Makefile.patch
- sha1sums = SKIP
+ sha1sums = 28342768afab1e644a660b96051c04e5e9d3bcb0
sha1sums = b77624236aa8988085ae6bddd4ca18c5d2e11cb8
pkgname = ada_spawn
diff --git a/PKGBUILD b/PKGBUILD
index 3fbaf5090cb0..097cc6bf23af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,44 @@
# Maintainer: Rod Kay <rodakay5 at gmail dot com>
pkgname=ada_spawn
-pkgver=r69.725a42d
+epoch=1
+pkgver=21.0.0
pkgrel=1
-pkgdesc="A simple Ada API to spawn processes and communicate with them."
-arch=('x86_64')
+
+pkgdesc="A simple Ada API to start processes and communicate with them."
url="https://github.com/AdaCore/spawn"
+
+arch=('i686' 'x86_64')
license=('GPL3' 'custom')
-makedepends=('git' 'gcc-ada' 'gprbuild')
-source=("git+https://github.com/AdaCore/spawn.git#commit=725a42d9511ac414147dc9d7a2e16a6743e0f779"
+
+depends=('gtkada') # 'namcap' says gtkada dependency is not needed, yet it is needed to supply the ada glib binding.
+makedepends=('gprbuild')
+
+_name=spawn
+_version=2021-20210701-19A43-src
+_hash=28342768afab1e644a660b96051c04e5e9d3bcb0
+
+source=("$pkgname-$pkgver.tar.gz::https://community.download.adacore.com/v1/$_hash?filename=$pkgname-$_version.tar.gz&rand=1809"
"Makefile.patch")
-sha1sums=(SKIP
+sha1sums=($_hash
b77624236aa8988085ae6bddd4ca18c5d2e11cb8)
-pkgver() {
- cd "$srcdir/spawn"
- printf "r%s.%s" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- cd "$srcdir/spawn"
+prepare()
+{
+ cd "$srcdir/$_name-$_version"
patch -Np1 -i ../Makefile.patch
}
-build() {
- cd "$srcdir/spawn"
+build()
+{
+ cd "$srcdir/$_name-$_version"
export OS=unix
make all
}
-package() {
- cd "$srcdir/spawn"
+package()
+{
+ cd "$srcdir/$_name-$_version"
export OS=unix
DESTDIR=$pkgdir make install
@@ -46,10 +52,10 @@ package() {
# Install the license.
install -D -m644 \
"COPYING3" \
- "$pkgdir/usr/share/licenses/ada_spawn/COPYING3"
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
# Install the custom license.
install -D -m644 \
"COPYING.RUNTIME" \
- "$pkgdir/usr/share/licenses/ada_spawn/COPYING.RUNTIME"
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}