summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-01-10 20:09:04 +0100
committerBaptiste Jonglez2016-01-10 20:09:04 +0100
commitb10d3d45f6e8592ffc3973bf2111c60681e95274 (patch)
tree7a3c38d58a8800c1977c012efb13fba7f3e98294
downloadaur-b10d3d45f6e8592ffc3973bf2111c60681e95274.tar.gz
adanaxis-gpl: Initial package
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD39
-rw-r--r--const.patch12
-rw-r--r--gcc-4.7.patch11
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a29a32bfb626
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Sun Jan 10 19:09:04 UTC 2016
+pkgbase = adanaxis-gpl
+ pkgdesc = A deep space first-person shooter game in four spatial dimensions (GPL version, built from source)
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = http://www.mushware.com/portal.php
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ depends = libxext
+ depends = glu
+ depends = sdl
+ depends = sdl_mixer
+ depends = libvorbis
+ depends = libogg
+ depends = libtiff
+ depends = pcre
+ depends = expat
+ conflicts = adanaxis-gpl-deb
+ source = http://www.mushware.com/files/adanaxisgpl-1.2.5.tar.gz
+ source = gcc-4.7.patch
+ source = const.patch
+ md5sums = bd890ac60c875f7b114d722d16d5eb71
+ md5sums = 0d9367d86a34c78a107bf775d8b4ee2a
+ md5sums = dc66d718ae4389b5e02fa9238b33710e
+
+pkgname = adanaxis-gpl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10e92b64451d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+pkgname=adanaxis-gpl
+_name=adanaxisgpl
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="A deep space first-person shooter game in four spatial dimensions (GPL version, built from source)"
+arch=("i686" "x86_64")
+url="http://www.mushware.com/portal.php"
+license=('GPL')
+depends=("libx11" "libxext" "glu" "sdl" "sdl_mixer" "libvorbis" "libogg" "libtiff" "pcre" "expat")
+conflicts=("adanaxis-gpl-deb")
+install=
+source=("http://www.mushware.com/files/${_name}-$pkgver.tar.gz"
+ "gcc-4.7.patch"
+ "const.patch")
+md5sums=('bd890ac60c875f7b114d722d16d5eb71'
+ '0d9367d86a34c78a107bf775d8b4ee2a'
+ 'dc66d718ae4389b5e02fa9238b33710e')
+
+prepare() {
+ cd "$srcdir/${_name}-$pkgver"
+ # Required to build with gcc>=4.7, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667094
+ patch -p1 -i "$srcdir/gcc-4.7.patch"
+ # Constness issue
+ patch -p1 -i "$srcdir/const.patch"
+}
+
+build() {
+ cd "$srcdir/${_name}-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${_name}-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/const.patch b/const.patch
new file mode 100644
index 000000000000..d97ef461b857
--- /dev/null
+++ b/const.patch
@@ -0,0 +1,12 @@
+--- a/src/Platform/X11/PlatformMiscUtils.cpp 2007-07-03 15:30:16.000000000 +0200
++++ b/src/Platform/X11/PlatformMiscUtils.cpp 2016-01-10 19:28:13.647222781 +0100
+@@ -1237,7 +1237,8 @@
+ char *
+ br_dirname (const char *path)
+ {
+- char *end, *result;
++ const char *end;
++ char *result;
+
+ if (path == (const char *) NULL)
+ return (char *) NULL;
diff --git a/gcc-4.7.patch b/gcc-4.7.patch
new file mode 100644
index 000000000000..d6735a3bb960
--- /dev/null
+++ b/gcc-4.7.patch
@@ -0,0 +1,11 @@
+--- a/src/Mushcore/MushcoreSingleton.h 2016-01-10 19:03:45.514348553 +0100
++++ b/src/Mushcore/MushcoreSingleton.h 2016-01-10 19:03:37.481127086 +0100
+@@ -83,7 +83,7 @@
+ inline void
+ MushcoreSingleton<SingletonType>::SingletonUncheckedNew(void)
+ {
+- SingletonPtrSet(new SingletonType);
++ MushcoreSingleton::SingletonPtrSet(new SingletonType);
+
+ #ifdef MUSHCORE_SINGLETON_TESTING
+ cerr << "Created " << typeid(SingletonType).name() << " singleton " << endl;