summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiceMicro2020-05-10 19:25:49 +0900
committerNiceMicro2020-05-10 19:25:49 +0900
commitdfa376c7bd98126943e4a00d1b1a2e3f0ae85fb2 (patch)
tree818ef5a0b735a0af16881fbe8e37a5b0fea2a3a2
downloadaur-dfa376c7bd98126943e4a00d1b1a2e3f0ae85fb2.tar.gz
Initial commit of the PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04ec42ffd211
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = adapta-gtk-theme-colorpack-joshaby-git
+ pkgdesc = A beautiful GTK+ theme based in material design (git version from Joshaby).
+ pkgver = 1.202005091130.r0.g2bdf8a0
+ pkgrel = 1
+ url = https://github.com/Joshaby/Adapta-Colorpack
+ arch = any
+ license = GPL2
+ optdepends = ttf-roboto: recommended font
+ optdepends = noto-fonts: recommended font
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ provides = adapta-gtk-theme-colorpack
+ conflicts = adapta-gtk-theme-colorpack
+ options = !strip
+ source = git+https://github.com/Joshaby/Adapta-Colorpack.git
+ sha256sums = SKIP
+
+pkgname = adapta-gtk-theme-colorpack-joshaby-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..743781531935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: NiceMicro <nicemicro@freemail.hu>
+
+pkgname=adapta-gtk-theme-colorpack-joshaby-git
+_gitname=Adapta-Colorpack
+pkgver=1.202005091130.r0.g2bdf8a0
+pkgrel=1
+pkgdesc="A beautiful GTK+ theme based in material design (git version from Joshaby)."
+arch=('any')
+url="https://github.com/Joshaby/Adapta-Colorpack"
+license=('GPL2')
+depends=()
+optdepends=('ttf-roboto: recommended font'
+ 'noto-fonts: recommended font'
+ 'gtk-engine-murrine: for gtk2 themes')
+provides=('adapta-gtk-theme-colorpack')
+conflicts=('adapta-gtk-theme-colorpack')
+source=(git+"https://github.com/Joshaby/${_gitname}.git")
+sha256sums=('SKIP')
+options=('!strip')
+
+pkgver() {
+ cd ${_gitname}
+ git describe --long --tags | sed -e 's/^/1./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cp -r "${_gitname}/Pkg/usr" "${pkgdir}/usr"
+}
+