summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Robinson2021-09-15 01:11:11 -0400
committerNathan Robinson2021-09-15 01:11:11 -0400
commit595ea0f338131e30538e27a493caabc75a87357d (patch)
treec638018a9110c7366387013242dc30b7d70420cb
downloadaur-595ea0f338131e30538e27a493caabc75a87357d.tar.gz
initial commit at 01:11 of 2021-09-15
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD19
-rw-r--r--adapta-nokto-cinnamon-cantarell.hook12
-rw-r--r--cinnamon.css.patch10
-rwxr-xr-xrelease.sh5
6 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..097820fef06f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = adapta-nokto-cinnamon-cantarell
+ pkgdesc = Pacman hook to change Adapta Nokto Cinnamon font to Cantarell
+ pkgver = 0.1.0
+ pkgrel = 1
+ arch = any
+ license = GPL2
+ depends = patch
+ optdepends = cantarell-fonts
+ optdepends = adapta-gtk-theme
+ source = adapta-nokto-cinnamon-cantarell.hook
+ source = cinnamon.css.patch
+ sha256sums = a3317a6b5b905ae90d8bcdd6db17b57dba1bab531d1d2808aee04495d7c65839
+ sha256sums = 55403fc3719ed43ba69f6230f7b3e7cff78d154a2a996b42e40819607edf1d82
+
+pkgname = adapta-nokto-cinnamon-cantarell
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91f575a527c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.zst
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9dc7f45a37e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nathan Robinson <nrobinson2000@me.com>
+pkgname=adapta-nokto-cinnamon-cantarell
+pkgver=0.1.0
+pkgrel=1
+arch=('any')
+license=('GPL2')
+depends=('patch')
+optdepends=('cantarell-fonts' 'adapta-gtk-theme')
+
+pkgdesc="Pacman hook to change Adapta Nokto Cinnamon font to Cantarell"
+
+source=($pkgname.hook cinnamon.css.patch)
+sha256sums=('a3317a6b5b905ae90d8bcdd6db17b57dba1bab531d1d2808aee04495d7c65839'
+ '55403fc3719ed43ba69f6230f7b3e7cff78d154a2a996b42e40819607edf1d82')
+
+package() {
+ install -Dm644 cinnamon.css.patch "$pkgdir/usr/share/$pkgname/cinnamon.css.patch"
+ install -Dm644 $pkgname.hook "$pkgdir/usr/share/libalpm/hooks/$pkgname.hook"
+}
diff --git a/adapta-nokto-cinnamon-cantarell.hook b/adapta-nokto-cinnamon-cantarell.hook
new file mode 100644
index 000000000000..d949487cbddf
--- /dev/null
+++ b/adapta-nokto-cinnamon-cantarell.hook
@@ -0,0 +1,12 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Type = Package
+Target = adapta-gtk-theme
+
+[Action]
+Description = Changing Adapta Nokto Cinnamon font to Cantarell...
+When = PostTransaction
+Depends = patch
+
+Exec = /usr/bin/patch -d/ -p0 -Nr- -i /usr/share/adapta-nokto-cinnamon-cantarell/cinnamon.css.patch
diff --git a/cinnamon.css.patch b/cinnamon.css.patch
new file mode 100644
index 000000000000..bd89d021d3d3
--- /dev/null
+++ b/cinnamon.css.patch
@@ -0,0 +1,10 @@
++++ /usr/share/themes/Adapta-Nokto/cinnamon/cinnamon.css
+@@ -1,7 +1,7 @@
+ /* This file is part of adapta-gtk-theme Copyright (C) 2016-2018 Tista <tista.gma500@gmail.com> This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. */
+ * { transition-timing-function: cubic-bezier(0.4, 0, 0.2, 1); transition-duration: 0.2s; }
+
+-stage { font-size: 10pt; color: #CFD8DC; font-family: Roboto, Sans-Serif; font-weight: 400; }
++stage { font-size: 10pt; color: #CFD8DC; font-family: Cantarell, Regular; font-weight: 400; }
+
+ .label-shadow { color: transparent; }
+
diff --git a/release.sh b/release.sh
new file mode 100755
index 000000000000..4caeaa1baa65
--- /dev/null
+++ b/release.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+updpkgsums
+makepkg -sif
+makepkg --printsrcinfo > .SRCINFO