summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:10:45 +0100
committermschubert2015-06-12 12:10:45 +0100
commit97591447712f4664c410617527b3800bfe5904d9 (patch)
tree7f5329d6e2d6fb2aa891df8b123f705946d334f5
downloadaur-97591447712f4664c410617527b3800bfe5904d9.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ba02794cfba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = adaptagrams-git
+ pkgdesc = A library of tools and reusable code for adaptive diagramming applications
+ pkgver = r1171.997b13d
+ pkgrel = 1
+ url = http://adaptagrams.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ optdepends = cairo
+ options = !libtool
+ source = adaptagrams-git::git+https://github.com/mjwybrow/adaptagrams.git
+ md5sums = SKIP
+
+pkgname = adaptagrams-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae75b230177f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=adaptagrams-git
+pkgver=r1171.997b13d
+pkgrel=1
+pkgdesc="A library of tools and reusable code for adaptive diagramming applications"
+arch=('i686' 'x86_64')
+url=("http://adaptagrams.sourceforge.net/")
+license=('LGPL')
+optdepends=('cairo')
+makedepends=('git')
+options=('!libtool')
+source=($pkgname::git+https://github.com/mjwybrow/adaptagrams.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/$pkgname/cola"
+ mkdir m4 || true
+ aclocal
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/cola"
+ make DESTDIR="$pkgdir" install
+ install -m644 "libcola/exceptions.h" "$pkgdir/usr/include/libcola/"
+}
+