summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcedric.farinazzo2019-05-31 14:55:35 +0200
committercedric.farinazzo2019-05-31 14:55:35 +0200
commit1b1a46538c3b154fdacf35611b791de8f5cdc3ac (patch)
tree7ec93497aa8228cf3a914ddee35ce443e0a1bf60
parent7aef9a9987a11c0a8e9e7162def5b5ad02adfbab (diff)
downloadaur-1b1a46538c3b154fdacf35611b791de8f5cdc3ac.tar.gz
ANN: 0.1.1.4
Signed-off-by: cedric.farinazzo <cedric.farinazzo@epita.fr>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36703d1c3d2e..e7ec824461ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = adaptativeneuralnetwork
pkgdesc = AdaptativeNeuralNetwork : A static library containing multiple neural network models written in C
- pkgver = 0.1.1.3
+ pkgver = 0.1.1.4
pkgrel = 0
url = https://gitlab.com/cedricfarinazzo/adaptativeneuralnetwork
arch = any
@@ -11,7 +11,7 @@ pkgbase = adaptativeneuralnetwork
makedepends = gcc
depends = glibc
depends = graphviz
- source = https://github.com/cedricfarinazzo/AdaptativeNeuralNetwork/archive/0.1.1.3.tar.gz
+ source = https://github.com/cedricfarinazzo/AdaptativeNeuralNetwork/archive/0.1.1.4-1.tar.gz
md5sums = SKIP
pkgname = adaptativeneuralnetwork
diff --git a/PKGBUILD b/PKGBUILD
index ab4aeb6e902f..604a7b79e7d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=adaptativeneuralnetwork
_fullname=AdaptativeNeuralNetwork
pkgbase=adaptativeneuralnetwork
-pkgver=0.1.1.3
+pkgver=0.1.1.4
+_fullver=0.1.1.4-1
pkgrel=0
epoch=
pkgdesc="AdaptativeNeuralNetwork : A static library containing multiple neural network models written in C"
@@ -15,11 +16,11 @@ optdepends=()
makedepends=('make' 'cmake' 'gcc')
checkdepends=('criterion')
provides=()
-source=("https://github.com/cedricfarinazzo/${_fullname}/archive/${pkgver}.tar.gz")
+source=("https://github.com/cedricfarinazzo/${_fullname}/archive/${_fullver}.tar.gz")
md5sums=('SKIP')
build() {
- cd "$srcdir/$_fullname-$pkgver"
+ cd "$srcdir/$_fullname-$_fullver"
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=RELEASE \
@@ -30,14 +31,14 @@ build() {
}
check() {
- cd "$srcdir/$_fullname-$pkgver"
+ cd "$srcdir/$_fullname-$_fullver"
cd build
make check
}
package() {
- cd "$srcdir/$_fullname-$pkgver"
+ cd "$srcdir/$_fullname-$_fullver"
cd build
make DESTDIR=$pkgdir LIBDIR=$pkgdir/usr/lib install
}