summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcedric.farinazzo2019-05-30 00:12:31 +0200
committercedric.farinazzo2019-05-30 00:12:31 +0200
commit7aef9a9987a11c0a8e9e7162def5b5ad02adfbab (patch)
treea6ccf59357400985a54021b9f8e9c6ed5907047d
downloadaur-7aef9a9987a11c0a8e9e7162def5b5ad02adfbab.tar.gz
ANN: 0.1.1.3
Signed-off-by: cedric.farinazzo <cedric.farinazzo@epita.fr>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36703d1c3d2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = adaptativeneuralnetwork
+ pkgdesc = AdaptativeNeuralNetwork : A static library containing multiple neural network models written in C
+ pkgver = 0.1.1.3
+ pkgrel = 0
+ url = https://gitlab.com/cedricfarinazzo/adaptativeneuralnetwork
+ arch = any
+ license = MIT
+ checkdepends = criterion
+ makedepends = make
+ makedepends = cmake
+ makedepends = gcc
+ depends = glibc
+ depends = graphviz
+ source = https://github.com/cedricfarinazzo/AdaptativeNeuralNetwork/archive/0.1.1.3.tar.gz
+ md5sums = SKIP
+
+pkgname = adaptativeneuralnetwork
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab4aeb6e902f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Cédric FARINAZZO <cedric.farinazzo@gmail.com>
+
+pkgname=adaptativeneuralnetwork
+_fullname=AdaptativeNeuralNetwork
+pkgbase=adaptativeneuralnetwork
+pkgver=0.1.1.3
+pkgrel=0
+epoch=
+pkgdesc="AdaptativeNeuralNetwork : A static library containing multiple neural network models written in C"
+arch=(any)
+url="https://gitlab.com/cedricfarinazzo/adaptativeneuralnetwork"
+license=('MIT')
+depends=('glibc' 'graphviz')
+optdepends=()
+makedepends=('make' 'cmake' 'gcc')
+checkdepends=('criterion')
+provides=()
+source=("https://github.com/cedricfarinazzo/${_fullname}/archive/${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_fullname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=RELEASE \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+ make
+}
+
+check() {
+ cd "$srcdir/$_fullname-$pkgver"
+ cd build
+ make check
+}
+
+
+package() {
+ cd "$srcdir/$_fullname-$pkgver"
+ cd build
+ make DESTDIR=$pkgdir LIBDIR=$pkgdir/usr/lib install
+}