summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Tardieu2015-09-22 00:51:02 +0200
committerSamuel Tardieu2015-09-22 00:51:02 +0200
commit55111a96fc399db6c1050c079aa74c3744c07b29 (patch)
tree66f82e0bada8c3a38636b693aea475477ff59b35
downloadaur-55111a96fc399db6c1050c079aa74c3744c07b29.tar.gz
AdaSockets 1.9
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--adasockets.install22
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18f77a08d74c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v7
+# Mon Sep 21 22:50:52 UTC 2015
+pkgbase = adasockets
+ pkgdesc = BSD sockets in Ada
+ pkgver = 1.9
+ pkgrel = 1
+ url = http://www.rfc1149.net/devel/adasockets
+ install = adasockets.install
+ arch = i686
+ arch = x86_64
+ license = custom:GNAT_Modified_GPL
+ makedepends = gcc-ada
+ makedepends = autogen
+ depends = sh
+ options = !libtool
+ source = http://www.rfc1149.net/download/adasockets/adasockets-1.9.tar.gz
+ md5sums = efa79c2d1e4a7be698bdfb775ed1fc80
+
+pkgname = adasockets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddef5d140d8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Samuel Tardieu <sam@rfc1149.net>
+
+pkgname=adasockets
+pkgver=1.9
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="BSD sockets in Ada"
+url="http://www.rfc1149.net/devel/adasockets"
+license=('custom:GNAT_Modified_GPL')
+depends=('sh')
+makedepends=('gcc-ada' 'autogen')
+options=('!libtool')
+install=adasockets.install
+source=(http://www.rfc1149.net/download/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('efa79c2d1e4a7be698bdfb775ed1fc80')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}/" install
+ install -D -m 644 GMGPL ${pkgdir}/usr/share/licenses/$pkgname/GNAT_Modified_GPL
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/adasockets.install b/adasockets.install
new file mode 100644
index 000000000000..7fc0afb43418
--- /dev/null
+++ b/adasockets.install
@@ -0,0 +1,22 @@
+infodir=usr/share/info
+filelist=(adasockets.info)
+
+post_install() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in "${filelist[@]}"; do
+ install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in "${filelist[@]}"; do
+ install-info --delete "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: