summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:43:19 -0700
committerAnatol Pomozov2015-06-17 08:43:19 -0700
commit01a15c2f52d8ff3669b55d4d0a494fc358987656 (patch)
tree0334872d1eb0ae693bbe05ea4ef479db60d70ebc
downloadaur-01a15c2f52d8ff3669b55d4d0a494fc358987656.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff8d8571d17c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = adb-sync-git
+ pkgdesc = A tool to synchronize files between a PC and an Android device using the ADB
+ pkgver = r14.9b9a704
+ pkgrel = 1
+ url = https://github.com/google/adb-sync
+ arch = any
+ license = Apache
+ depends = python2
+ source = git+https://github.com/google/adb-sync
+ sha1sums = SKIP
+
+pkgname = adb-sync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d3311fdbe42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+
+pkgname=adb-sync-git
+pkgver=r14.9b9a704
+pkgrel=1
+pkgdesc='A tool to synchronize files between a PC and an Android device using the ADB'
+url='https://github.com/google/adb-sync'
+arch=(any)
+depends=(python2)
+license=(Apache)
+source=(git+https://github.com/google/adb-sync)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd adb-sync
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ sed 's|^#!/usr/bin/python|#!/usr/bin/python2|' -i adb-sync/adb-sync
+}
+
+package() {
+ cd adb-sync
+ install -m755 -d "$pkgdir/usr/bin"
+ install -m755 -t "$pkgdir/usr/bin" adb-sync adb-channel
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}