summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122022-11-11 09:05:38 +0100
committerwillemw122022-11-11 09:05:38 +0100
commit9ccdf2d72831ef06aa9ed3cccbace797e98c07f2 (patch)
tree466f28e4d2df72e131dcb7dc0f0834d8a27e340e
parent8a363d683dd77b804c18355d8ce8559ade9fb04d (diff)
downloadaur-9ccdf2d72831ef06aa9ed3cccbace797e98c07f2.tar.gz
Add provides and conflicts. Install license file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36c8458038e5..785e681fc9bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,8 @@ pkgbase = adb-sync-git
depends = android-tools
depends = android-udev
depends = python
+ provides = adb-sync
+ conflicts = adb-sync
source = adb-sync-git::git+https://github.com/google/adb-sync.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 10cfec1db580..7fe358571236 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
pkgname=adb-sync-git
-pkgver=r35.fb7c549
+pkgver=r36.76b2783
pkgrel=1
pkgdesc='Synchronize files between a PC and an Android device using the ADB (Android Debug Bridge)'
arch=('any')
@@ -10,6 +10,8 @@ url='https://github.com/google/adb-sync'
license=('Apache')
depends=('android-tools' 'android-udev' 'python')
makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
@@ -20,5 +22,6 @@ pkgver() {
package() {
install -Dm755 $pkgname/{adb-sync,adb-channel} -t "$pkgdir/usr/bin"
+ install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}