summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-08-12 23:48:58 -0700
committerAnatol Pomozov2015-08-12 23:48:58 -0700
commit183825576e5dcd342d0fab6de23a739c197be3ec (patch)
tree75305740f7a77e5cdc79a4ef2951604ed537f98f
downloadaur-adbfs-git.tar.gz
adbfs init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27b43b98bd3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = adbfs-git
+ pkgdesc = fuse filesystem over adb tool for android devices
+ pkgver = r41.b687e00
+ pkgrel = 1
+ url = https://github.com/isieo/adbFS
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = gcc-libs
+ depends = fuse
+ source = git+https://github.com/isieo/adbFS
+ sha1sums = SKIP
+
+pkgname = adbfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e78b083307b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=adbfs-git
+pkgver=r41.b687e00
+pkgrel=1
+pkgdesc='fuse filesystem over adb tool for android devices'
+arch=(i686 x86_64)
+url='https://github.com/isieo/adbFS'
+license=(BSD)
+depends=(gcc-libs fuse)
+makedepends=(git)
+source=(git+https://github.com/isieo/adbFS)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd adbFS
+ echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd adbFS
+ make
+}
+
+package() {
+ cd adbFS
+ install -Dm755 adbfs "$pkgdir/usr/bin/adbfs"
+ install -Dm644 license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}