summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenneth Endfinger2020-02-11 03:06:22 -0500
committerKenneth Endfinger2020-02-11 03:06:37 -0500
commit292f99f18a2035400c9cb99e9bacab7ceebfe68b (patch)
treecec845ffd74bdf0802317c60c517e1f5e6e38794
parentf41e18d71d98fd714a56b008f8e5b41f6e0320bd (diff)
downloadaur-292f99f18a2035400c9cb99e9bacab7ceebfe68b.tar.gz
Take over maintainership
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD22
-rwxr-xr-xcheck-for-update.sh17
4 files changed, 43 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 208189096b0f..766f99611fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
-# Generated by mksrcinfo v8
-# Fri Apr 12 09:18:10 UTC 2019
pkgbase = addinclude
- pkgdesc = Add include statements to header- and sourcefiles, for C and C++
+ pkgdesc = Add include statements to header and sourcefiles, for C and C++
pkgver = 1.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://addinclude.roboticoverlords.org/
+ arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL2
makedepends = go
source = https://addinclude.roboticoverlords.org/addinclude-1.0.1.tar.xz
source = https://addinclude.roboticoverlords.org/addinclude-1.0.1.tar.xz.asc
- sha256sums = af3f5a7d3472b6a871150d82b9905e6a6571ad8d80820e382e20179c7aac2e67
- sha256sums = SKIP
+ validpgpkeys = 962855F072C7A01846405864FCF3C8CB5CF9C8D4
+ sha512sums = bb73427f85abd747104e2b24c19da3e1daf31ee0af2f1da5c268ef47cd8657c2e06d6a0611c153afeae1492752926f3765521643ee41a6337a7fe40ca55336aa
+ sha512sums = SKIP
pkgname = addinclude
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d8ef4c0a6c9b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/src
+/pkg
+*.xz
+*.tar.*
+*.pkg.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 81dcc299b263..aaa7204dcb93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=addinclude
pkgver=1.0.1
-pkgrel=3
-pkgdesc='Add include statements to header- and sourcefiles, for C and C++'
-arch=(x86_64)
+pkgrel=4
+pkgdesc='Add include statements to header and sourcefiles, for C and C++'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://addinclude.roboticoverlords.org/'
-license=(GPL2)
-makedepends=(go)
+license=('GPL2')
+makedepends=('go')
source=("https://addinclude.roboticoverlords.org/$pkgname-$pkgver.tar.xz"{,.asc})
validpgpkeys=('962855F072C7A01846405864FCF3C8CB5CF9C8D4')
-sha256sums=('af3f5a7d3472b6a871150d82b9905e6a6571ad8d80820e382e20179c7aac2e67'
+sha512sums=('bb73427f85abd747104e2b24c19da3e1daf31ee0af2f1da5c268ef47cd8657c2e06d6a0611c153afeae1492752926f3765521643ee41a6337a7fe40ca55336aa'
'SKIP')
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- install -Dm755 $pkgname-$pkgver "$pkgdir/usr/bin/$pkgname"
- install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm755 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
}
# vim: ts=2 sw=2 et:
diff --git a/check-for-update.sh b/check-for-update.sh
new file mode 100755
index 000000000000..a7823c96886d
--- /dev/null
+++ b/check-for-update.sh
@@ -0,0 +1,17 @@
+#!/usr/bin/env bash
+set -e
+
+cd $(dirname "${0}")
+
+REPOSITORY="xyproto/addinclude"
+
+PKG=$(cat .SRCINFO | grep "pkgbase" | head -n1 | awk '{print $3}')
+CURRENT=$(cat .SRCINFO | grep "pkgver" | head -n1 | awk '{print $3}')
+LATEST=$(curl -n --silent -L "https://api.github.com/repos/${REPOSITORY}/tags" | jq -r '.[].name' | grep -v -- "-" | sed 's/v//g' | sort --version-sort | tail -n1)
+if [ "${LATEST}" != "${CURRENT}" ]
+then
+ echo "${PKG} : AUR ${CURRENT} != GitHub ${LATEST}"
+ exit 1
+fi
+echo "${PKG} : AUR ${CURRENT} == GitHub ${LATEST}"
+exit 0