summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-04-12 11:18:15 +0200
committerAlexander F. Rødseth2019-04-12 11:18:15 +0200
commitf41e18d71d98fd714a56b008f8e5b41f6e0320bd (patch)
tree6bd9ba9252345d857bd33511a049506acad0295f
parentd538d433c02957a475331b06faf9a6c0a01ab912 (diff)
downloadaur-f41e18d71d98fd714a56b008f8e5b41f6e0320bd.tar.gz
Use the "go" package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 122053544722..208189096b0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Thu Apr 4 07:52:39 UTC 2019
+# Fri Apr 12 09:18:10 UTC 2019
pkgbase = addinclude
pkgdesc = Add include statements to header- and sourcefiles, for C and C++
pkgver = 1.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://addinclude.roboticoverlords.org/
arch = x86_64
license = GPL2
- makedepends = gcc-go
+ makedepends = go
source = https://addinclude.roboticoverlords.org/addinclude-1.0.1.tar.xz
source = https://addinclude.roboticoverlords.org/addinclude-1.0.1.tar.xz.asc
sha256sums = af3f5a7d3472b6a871150d82b9905e6a6571ad8d80820e382e20179c7aac2e67
diff --git a/PKGBUILD b/PKGBUILD
index 16adb5440215..81dcc299b263 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,27 @@
pkgname=addinclude
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
pkgdesc='Add include statements to header- and sourcefiles, for C and C++'
arch=(x86_64)
url='https://addinclude.roboticoverlords.org/'
license=(GPL2)
-makedepends=(gcc-go)
+makedepends=(go)
source=("https://addinclude.roboticoverlords.org/$pkgname-$pkgver.tar.xz"{,.asc})
validpgpkeys=('962855F072C7A01846405864FCF3C8CB5CF9C8D4')
sha256sums=('af3f5a7d3472b6a871150d82b9905e6a6571ad8d80820e382e20179c7aac2e67'
'SKIP')
build() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
- go build -gccgoflags "-Wl,-z,relro,-z,now" -o $pkgname
+ go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
}
package() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname-$pkgver "$pkgdir/usr/bin/$pkgname"
install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
}