summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2022-02-19 17:02:12 -0700
committernot_anonymous2022-02-19 17:02:12 -0700
commit8e99d943cbc0a2b7143f3b3b9a84a38791e4b506 (patch)
tree0a2578c4fca45a55640d0b39e3b2d380507a1e83
downloadaur-8e99d943cbc0a2b7143f3b3b9a84a38791e4b506.tar.gz
New
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71c1c7b7363b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = addinclude-git
+ pkgdesc = Add include statements to header and sourcefiles, for C and C++
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/xyproto/addinclude
+ arch = x86_64
+ license = GPL2
+ makedepends = go
+ provides = addinclude
+ conflicts = addinclude
+ source = addinclude::git://github.com/xyproto/addinclude.git#branch=main
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = addinclude-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5f9a6fd19fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
+
+pkgname=addinclude-git
+_pkgname=addinclude
+_authorname=xyproto
+pkgver=1.1.1
+#.r1.g9d6e3c8
+pkgrel=1
+pkgdesc='Add include statements to header and sourcefiles, for C and C++'
+arch=(x86_64)
+url='https://github.com/xyproto/addinclude'
+license=(GPL2)
+makedepends=(go)
+provides=(addinclude)
+conflicts=(addinclude)
+source=("${_pkgname}::git://github.com/${_authorname}/${_pkgname}.git#branch=main")
+
+pkgver() {
+ cd "${_pkgname}"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\""
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 $_pkgname.1 "$pkgdir/usr/share/man/man1/$_pkgname.1"
+}
+md5sums=('SKIP')
+sha256sums=('SKIP')