summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2018-09-04 18:32:52 -0600
committerBrian Bidulock2018-09-04 18:32:52 -0600
commit20e59b3a8d59a618fee8403db87d7545f1526a5d (patch)
tree9e1f20dc8261e870fa74de61d097ea0968466b3a
parent4960a78d1012c70e570588821d0d38ae961ae068 (diff)
downloadaur-20e59b3a8d59a618fee8403db87d7545f1526a5d.tar.gz
adjust rules and service
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--addrwatch.rules10
-rw-r--r--addrwatch.service2
4 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a03b0f70c05..bbde0ac0bd42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = addrwatch
pkgdesc = A tool similar to arpwatch for IPv4/IPv6 and ethernet address pairing monitoring
pkgver = 1.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/fln/addrwatch
arch = x86_64
arch = i686
@@ -12,8 +12,8 @@ pkgbase = addrwatch
source = addrwatch.service
source = addrwatch.rules
sha512sums = bc6f9193bc5dec3b2716ba220d274409fc0a220f5441dcdae5b1fef5e2e1d405898023944fe45263d2869861bb4dec3691d0de04a36eb89cb835e118341a0c8d
- sha512sums = 2bc8cdb4b0b8906fd52c5b9e56e1cd2b1d8416a38ced1d33f8b0c9e0f739cde0ecc2e9267e1b1256c0e189fe53c66b69f8ab5a64addb77adf87ffa327f84b5c6
- sha512sums = 69e2213923ada91ac32191f7747a6314f5a12fe8b644b07725d8d6441e411e6b597017eaf6f9336a26de0cb6bf7c46bb241462933d5b483dc3a026c499d999bd
+ sha512sums = 35aeb27ed449c29780a1a1ec0b9cf4efafdca2397e94d15e1590244e3799b14c29d043dcce9d68be341423fc56fac9c6ed62c0f95ce1efbb5603d0509bc9e935
+ sha512sums = ec8fdcc3d88ed433e5fc28e6c0394ddae7af8d2085e37872bbd85127e1c008b2d3e541644cc28a3d05e9ff8718964205d43b1661d580300b1696789a98ba4c29
pkgname = addrwatch
diff --git a/PKGBUILD b/PKGBUILD
index 8d7913d0b307..827e3c1d557c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=addrwatch
pkgver=1.0.1
-pkgrel=3
+pkgrel=4
pkgdesc='A tool similar to arpwatch for IPv4/IPv6 and ethernet address pairing monitoring'
arch=('x86_64' 'i686')
url="https://github.com/fln/addrwatch"
@@ -30,5 +30,5 @@ END
}
sha512sums=('bc6f9193bc5dec3b2716ba220d274409fc0a220f5441dcdae5b1fef5e2e1d405898023944fe45263d2869861bb4dec3691d0de04a36eb89cb835e118341a0c8d'
- '2bc8cdb4b0b8906fd52c5b9e56e1cd2b1d8416a38ced1d33f8b0c9e0f739cde0ecc2e9267e1b1256c0e189fe53c66b69f8ab5a64addb77adf87ffa327f84b5c6'
- '69e2213923ada91ac32191f7747a6314f5a12fe8b644b07725d8d6441e411e6b597017eaf6f9336a26de0cb6bf7c46bb241462933d5b483dc3a026c499d999bd')
+ '35aeb27ed449c29780a1a1ec0b9cf4efafdca2397e94d15e1590244e3799b14c29d043dcce9d68be341423fc56fac9c6ed62c0f95ce1efbb5603d0509bc9e935'
+ 'ec8fdcc3d88ed433e5fc28e6c0394ddae7af8d2085e37872bbd85127e1c008b2d3e541644cc28a3d05e9ff8718964205d43b1661d580300b1696789a98ba4c29')
diff --git a/addrwatch.rules b/addrwatch.rules
index 2c0a8dba7acf..bc752df336a9 100644
--- a/addrwatch.rules
+++ b/addrwatch.rules
@@ -1,3 +1,7 @@
-ACTION=="remove", GOTO="addrwatch_end"
-SUBSYSTEM=="net", KERNEL=="eth*|usb*|en*|wlan*", TAG+="systemd", ENV{SYSTEMD_ALIAS}+="/sys/subsystem/net/devices/$name", ENV{SYSTEMD_WANTS}+="addrwatch@%k.service"
-LABEL="addrwatch_end"
+#
+# copy this file to /etc/udev/rules.d and uncomment the links that follow to start
+# addrwatch on ethernet interfaces
+#
+#ACTION=="remove", GOTO="addrwatch_end"
+#SUBSYSTEM=="net", KERNEL=="eth*|usb*|en*|wlan*", TAG+="systemd", ENV{SYSTEMD_ALIAS}+="/sys/subsystem/net/devices/$name", ENV{SYSTEMD_WANTS}+="addrwatch@%k.service"
+#LABEL="addrwatch_end"
diff --git a/addrwatch.service b/addrwatch.service
index c2a7ba538f1b..fa49a63e0306 100644
--- a/addrwatch.service
+++ b/addrwatch.service
@@ -5,7 +5,7 @@ Wants=systemd-network-wait-online.service
[Service]
Type=simple
-ExecStart=/usr/bin/addrwatch -o /var/lib/addrwatch/%i.dat %i
+ExecStart=/usr/bin/addrwatch -q -o /var/lib/addrwatch/%i.dat %i
[Install]
WantedBy=multi-user.target