summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorleipero2017-09-29 20:05:00 +0200
committerleipero2017-09-29 20:05:00 +0200
commit4cb7fc2c6ef54fd0bece478a51889c7a063126f1 (patch)
tree999e4106cfc81328b3e8fa028381f88ba3bc07d6
parentb5862e11efdd85b30af6cff7dd0687656e7dcf58 (diff)
downloadaur-4cb7fc2c6ef54fd0bece478a51889c7a063126f1.tar.gz
optimizing package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44c5660cd914..be4260226b32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,12 +7,13 @@ pkgbase = adg-gtk-theme
license = GPL
makedepends = sassc
makedepends = git
+ makedepends = libarchive
depends = gtk-engine-murrine
optdepends = optipng
optdepends = inkscape
options = !emptydirs
source = adg-gtk-theme-3.22.3.tar.gz::https://github.com/leipero/adg-gtk-theme/archive/3.22.3.tar.gz
- sha256sums = 3956c7cf438d19245f63f4a03b6a393e070ef95dc826b8e029d2ac1793c5d304
+ sha256sums = a47c0af0a88ccb062b81378adfadfceeaab8ffd5b642686b46ff13fe76fa6f1c
pkgname = adg-gtk-theme
diff --git a/PKGBUILD b/PKGBUILD
index d0903eb9a457..0c3fa8b3bdd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,26 +8,24 @@ url="https://github.com/leipero/adg-gtk-theme"
arch=(any)
license=(GPL)
depends=('gtk-engine-murrine')
-makedepends=('sassc' 'git')
+makedepends=('sassc' 'git' 'libarchive')
optdepends=('optipng' 'inkscape')
options=(!emptydirs)
-source=("adg-gtk-theme-$pkgver.tar.gz"::"https://github.com/leipero/adg-gtk-theme/archive/$pkgver.tar.gz")
-sha256sums=('3956c7cf438d19245f63f4a03b6a393e070ef95dc826b8e029d2ac1793c5d304')
+source=("adg-gtk-theme-$pkgver.tar.gz"::"https://github.com/leipero/adg-gtk-theme/archive/3.22.3.tar.gz")
+sha256sums=('a47c0af0a88ccb062b81378adfadfceeaab8ffd5b642686b46ff13fe76fa6f1c')
build() {
cd "$pkgname-$pkgver"
./configure
make
- make install
}
package() {
cd "$pkgname-$pkgver"
- install -dm755 "$pkgdir/usr/share/themes"
+ install -dm755 "$pkgdir/usr/share"
- cp -r "$srcdir"/$pkgname-$pkgver/themes/ "$pkgdir/usr/share"
+ cp -r "$srcdir"/$pkgname-$pkgver/build-aux/themes "$pkgdir/usr/share"
make DESTDIR="$pkgdir/"
- make uninstall
make clean
}