summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-03-26 16:16:30 +0200
committerfelics2018-03-26 16:16:30 +0200
commit060c36fa206a053cfaf020d3e1a88da01b7c17d0 (patch)
treed704eead5bf584ed30c0f2197cb7466a378004dc
parent925779445a788568eda8ec8400b409a2a7d694c2 (diff)
downloadaur-060c36fa206a053cfaf020d3e1a88da01b7c17d0.tar.gz
Fixed an error where local loopback interface falsely get NAT configured in default settings.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xadhocspot.sh2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a433e29edb5d..f8d6a9c55d35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = adhocspot-script
pkgdesc = Bash script to easily configure your interface to share your internet connection and configure a DHCP and DNS and TFTP boot server to listen on it. IP, DHCP, DNS can be configured, and for WiFi interfaces also wireless mode and encryption.
- pkgver = 20180326.1
+ pkgver = 20180326.2
pkgrel = 1
epoch = 0
install = adhocspot-script.install
@@ -15,7 +15,7 @@ pkgbase = adhocspot-script
source = adhocspot.sh
source = copying.txt
source = adhocspot-script.install
- sha256sums = fa4fbe502b49bddbe36f4c89a6491b99bd94335e2570abacc29f11328060bc5b
+ sha256sums = b2247253c0e3866f4b8631eecb81bb773f3abbaa84ca317ab23c2b6eb725494f
sha256sums = c3cbff25307e905545788f5c74cc137d79706c60549092f2a37919b93cf55ee3
sha256sums = f05052583b9d7ba8215897bc621fea38d18fea20e1040fcbda4fd2ab76fc8867
diff --git a/PKGBUILD b/PKGBUILD
index 7d9a6835be5b..c6ac1557a1cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=adhocspot-script
pkgname="${_pkgname}"
epoch=0
-pkgver=20180326.1
+pkgver=20180326.2
pkgrel=1
pkgdesc="Bash script to easily configure your interface to share your internet connection and configure a DHCP and DNS and TFTP boot server to listen on it. IP, DHCP, DNS can be configured, and for WiFi interfaces also wireless mode and encryption."
arch=('any')
@@ -41,7 +41,7 @@ source=(
)
sha256sums=(
- "fa4fbe502b49bddbe36f4c89a6491b99bd94335e2570abacc29f11328060bc5b"
+ "b2247253c0e3866f4b8631eecb81bb773f3abbaa84ca317ab23c2b6eb725494f"
"c3cbff25307e905545788f5c74cc137d79706c60549092f2a37919b93cf55ee3"
"f05052583b9d7ba8215897bc621fea38d18fea20e1040fcbda4fd2ab76fc8867"
)
diff --git a/adhocspot.sh b/adhocspot.sh
index 86e1b92abd9f..7e57564a079b 100755
--- a/adhocspot.sh
+++ b/adhocspot.sh
@@ -205,7 +205,7 @@ get_nat_interfaces() {
# Returns a newline-separated list of interfaces to add masquerading to their postrouting queue. Examines $_out_iface_all: If $_out_iface_all is true, returns all available interfaces whose name does not start with 'lo'. Otherwise, returns ${_out_iface}.
_nat_ifaces=""
if "${_out_iface_all}"; then
- _nat_ifaces="$(ifconfig -a | grep -E '^[^[[:space:]]]*' | awk '{print $1}' | sed 's|\:$||g')"
+ _nat_ifaces="$(ifconfig -a | grep -E '^[^[[:space:]]]*' | awk '{print $1}' | sed 's|\:$||g' | grep -vE '^lo')"
else
_nat_ifaces="${_out_iface}"
fi