summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktea2020-08-05 19:54:39 +0800
committerblacktea2020-08-05 19:54:39 +0800
commit13892c4b8ea1232430e38af056bc4f4abbd2bcdb (patch)
treeeec877dbb5849e1a8c5cc669c569d78d27cee163
downloadaur-13892c4b8ea1232430e38af056bc4f4abbd2bcdb.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9d9d1a9dccd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = adios2-git
+ pkgdesc = Next generation of ADIOS developed in the Exascale Computing Program
+ pkgver = 2.6.0.r256.gd96750bf
+ pkgrel = 1
+ url = https://adios2.readthedocs.io/en/latest/index.html
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = libpng
+ depends = zfp
+ depends = hdf5
+ depends = zeromq
+ depends = libfabric
+ depends = blosc
+ depends = python
+ depends = sz
+ provides = adios2
+ conflicts = adios2
+ source = $pkgname::git+https://github.com/ornladios/ADIOS2.git
+ md5sums = SKIP
+
+pkgname = adios2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe2935c5aefa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: blacktea <blackteahamburger@outlook.com>
+
+pkgname=adios2-git
+pkgver=2.6.0.r256.gd96750bf
+pkgrel=1
+pkgdesc="Next generation of ADIOS developed in the Exascale Computing Program"
+arch=('x86_64')
+url="https://adios2.readthedocs.io/en/latest/index.html"
+license=('Apache')
+depends=('libpng' 'zfp' 'hdf5' 'zeromq' 'libfabric' 'blosc' 'python' 'sz')
+makedepends=('cmake')
+provides=('adios2')
+conflicts=('adios2')
+source=('$pkgname::git+https://github.com/ornladios/ADIOS2.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname/
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname/
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -DADIOS2_BUILD_TESTING=OFF \
+ -DADIOS2_BUILD_EXAMPLES=OFF \
+ ..
+ make
+}
+
+package() {
+ cd $pkgname/
+ make DESTDIR="$pkgdir" install
+}