summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Brown2018-12-29 08:54:50 +0000
committerTimothy Brown2018-12-29 08:54:50 +0000
commit36cf63d2d73210e58c0c70185e70dee948c17a7a (patch)
treef4d9719c026b8c8f401dcf5c712a469ef386707a
downloadaur-36cf63d2d73210e58c0c70185e70dee948c17a7a.tar.gz
Initial Release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..463eecd6e982
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = adjtimex
+ pkgdesc = Allows configuration of kernel time variables
+ pkgver = 1.29_10
+ pkgrel = 1
+ url = https://github.com/rogers0/adjtimex
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL2
+ depends = glibc
+ source = adjtimex-1.29-10.tar.gz::https://github.com/rogers0/adjtimex/archive/debian/1.29-10.tar.gz
+ md5sums = 56e5c86c5fd5ef95d18673b2ed18e3f7
+
+pkgname = adjtimex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c173281dbc19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Timothy Brown <sysop@timb.us>
+pkgname=adjtimex
+pkgver=1.29_10
+pkgrel=1
+pkgdesc="Allows configuration of kernel time variables"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+ url="https://github.com/rogers0/adjtimex"
+license=('GPL2')
+depends=('glibc')
+source=("$pkgname-${pkgver//_/-}.tar.gz::https://github.com/rogers0/adjtimex/archive/debian/${pkgver//_/-}.tar.gz"
+ )
+build() {
+ cd "$pkgname-debian-${pkgver//_/-}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-debian-${pkgver//_/-}"
+ install -d ${pkgdir}/usr/{bin,share/man/man8}
+ make prefix="$pkgdir/usr" bindir="$pkgdir/usr/bin" install
+ chown root:root $pkgdir/usr/bin/adjtimex
+}
+md5sums=('56e5c86c5fd5ef95d18673b2ed18e3f7')