summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-05-11 15:14:18 +0200
committerJP Cimalando2018-05-11 15:14:18 +0200
commit9e7ca659c10a84a31691e0bc8bb105ee676eff8d (patch)
tree6988f641a30492d5ab3c5019a2653ba57a31f9ba
downloadaur-9e7ca659c10a84a31691e0bc8bb105ee676eff8d.tar.gz
adljack 1.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad7f4e078b53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = adljack
+ pkgdesc = OPL3/OPN2 synthesizer using ADLMIDI, for Jack and cross-platform audio
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jpcima/adljack
+ arch = i686
+ arch = x86_64
+ license = custom
+ license = GPL
+ license = LGPL
+ depends = jack
+ depends = alsa-lib
+ depends = libpulse
+ depends = liblo
+ depends = sdl2
+ source = https://github.com/jpcima/adljack/files/1995071/adljack-1.0.0.tar.gz
+ md5sums = 3ec1892386358fe7e1f76c667ae42e20
+
+pkgname = adljack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26a16344d3bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: JP Cimalando <jp-dev inbox.ru>
+pkgname=adljack
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="OPL3/OPN2 synthesizer using ADLMIDI, for Jack and cross-platform audio"
+arch=('i686' 'x86_64')
+url="https://github.com/jpcima/adljack"
+license=('custom' 'GPL' 'LGPL')
+groups=()
+depends=('jack' 'alsa-lib' 'libpulse' 'liblo' 'sdl2')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/jpcima/adljack/files/1995071/$pkgname-$pkgver.tar.gz")
+md5sums=('3ec1892386358fe7e1f76c667ae42e20')
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPREFER_PDCURSES=ON ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m 644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ cd build
+ make DESTDIR="$pkgdir/" install
+}