summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2019-02-12 03:25:44 +0100
committerJP Cimalando2019-02-12 03:34:39 +0100
commit3dd91cb8cc9bf4aa3aaea75141734d1920fa7ad6 (patch)
tree145f2fa4b890d71e74bbc2fed3a3c3853e928974
parentb018ef748935cf06dad1fe73cab85d9b2d2243be (diff)
downloadaur-3dd91cb8cc9bf4aa3aaea75141734d1920fa7ad6.tar.gz
update: new version, PKGBUILD fixes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 634b51fe8a7c..f522987c2f76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,6 @@
pkgbase = adlplug-git
- pkgver = v1.0.0.beta.3.r4.c60fdda
+ pkgdesc = FM chip synthesizer
+ pkgver = v1.0.0.beta.5.r15.bacf19b
pkgrel = 1
url = https://github.com/jpcima/ADLplug
arch = i686
@@ -7,10 +8,14 @@ pkgbase = adlplug-git
groups = pro-audio
license = GPL
makedepends = git
+ makedepends = cmake
+ makedepends = libxrandr
+ makedepends = libxinerama
+ makedepends = libxcursor
depends = jack
- depends = alsa-lib
depends = freetype2
depends = libxext
+ depends = hicolor-icon-theme
source = git+https://github.com/jpcima/ADLplug.git
source = git+https://github.com/Wohlstand/libADLMIDI.git
source = git+https://github.com/Wohlstand/libOPNMIDI.git
diff --git a/PKGBUILD b/PKGBUILD
index 1096e769cc72..3a27081210c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
pkgname=(adlplug-git opnplug-git)
_pkgname=ADLplug
-pkgver=v1.0.0.beta.3.r4.c60fdda
+pkgver=v1.0.0.beta.5.r15.bacf19b
pkgrel=1
+pkgdesc="FM chip synthesizer"
arch=('i686' 'x86_64')
url="https://github.com/jpcima/ADLplug"
license=('GPL')
groups=('pro-audio')
-depends=('jack' 'alsa-lib' 'freetype2' 'libxext')
-makedepends=('git')
+depends=('jack' 'freetype2' 'libxext' 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'libxrandr' 'libxinerama' 'libxcursor')
source=('git+https://github.com/jpcima/ADLplug.git'
'git+https://github.com/Wohlstand/libADLMIDI.git'
'git+https://github.com/Wohlstand/libOPNMIDI.git'
@@ -26,7 +27,7 @@ md5sums=('SKIP'
pkgver() {
cd "${srcdir}/${_pkgname}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "%s" "$(git describe --long --exclude nightly --exclude latest | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {