summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-09-08 09:38:57 +0200
committerJP Cimalando2018-09-08 09:38:57 +0200
commitaf4efdb82791181bdbee864dae710ef86990292e (patch)
tree01ce1e6392960eb4d53c4c0f1412be075f6fd47b
downloadaur-af4efdb82791181bdbee864dae710ef86990292e.tar.gz
Initial
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD59
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..312f405d3076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = adlplug-git
+ pkgdesc = FM synthesizer plugin for ADLMIDI with OPL3 chip emulation
+ pkgver = v1.0.0.alpha.3.r34.2e42c73
+ pkgrel = 1
+ url = https://github.com/jpcima/ADLplug
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = jack
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxext
+ provides = adlplug
+ conflicts = adlplug
+ source = git+https://github.com/jpcima/ADLplug.git
+ source = git+https://github.com/Wohlstand/libADLMIDI.git
+ source = git+https://github.com/Wohlstand/libOPNMIDI.git
+ source = git+https://github.com/jpcima/JUCE.git
+ source = git+https://github.com/fmtlib/fmt.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = adlplug-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1ec3a93dabb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Jean Pierre Cimalando <jp-dev@inbox.ru>
+pkgname=adlplug-git
+_pkgname=ADLplug
+pkgver=v1.0.0.alpha.3.r34.2e42c73
+pkgrel=1
+pkgdesc="FM synthesizer plugin for ADLMIDI with OPL3 chip emulation"
+arch=('i686' 'x86_64')
+url="https://github.com/jpcima/ADLplug"
+license=('GPL')
+groups=()
+depends=('jack' 'alsa-lib' 'freetype2' 'libxext')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/jpcima/ADLplug.git'
+ 'git+https://github.com/Wohlstand/libADLMIDI.git'
+ 'git+https://github.com/Wohlstand/libOPNMIDI.git'
+ 'git+https://github.com/jpcima/JUCE.git'
+ 'git+https://github.com/fmtlib/fmt.git')
+noextract=()
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ for submodule in \
+ thirdparty/libADLMIDI thirdparty/libOPNMIDI \
+ thirdparty/JUCE thirdparty/fmt
+ do
+ git config "submodule.$submodule.url" "$srcdir/`basename "$submodule"`"
+ done
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DADLplug_CHIP=OPL3 ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}